Bug Hunting Session
Bug 127920 - Ligatures enforced even when character spacing is increased
Summary: Ligatures enforced even when character spacing is increased
Status: RESOLVED DUPLICATE of bug 66819
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-10-02 09:18 UTC by Angelos Skembris
Modified: 2019-10-08 16:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with two words in increased character spacing. One has pair kerning enabled, the other one does not. (9.39 KB, application/vnd.oasis.opendocument.text)
2019-10-04 13:52 UTC, Angelos Skembris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Angelos Skembris 2019-10-02 09:18:25 UTC
Description:
I believe the "pair kerning" option is ignored for some (or all) fonts, resulting in poor visual results. E.g. for the Open Sans font, if you type "specifications" and increase character spacing, all spaces are increased except the space between "f" and "i", resulting in uneven letter spacing and a gap in the word. "f" and "i" remain attached to each other.  

Steps to Reproduce:
1.Write a word that possibly includes a kerned pair, like "specifications" (f-i, ti)
2.Select "Open Sans" font, "Calibri", "DejaVu Sans" or some other font (which possibly contains a kerning table
3.Right click on the word, select "Character -> Character", go to "position" tab, increase character spacing to e.g. 10pt. 

Actual Results:
The space between certain combinations like "f" and "i" remains the same even though other letters are spaced further apart. In "Calibri" font this also happens with "t" and "i". Clicking "Pair kerning" makes no difference to how the word is displayed. 

Expected Results:
Disabling pair kerning should result in all letters being evenly spaced (I guess it should be disabled anyway when character spacing is anything other than the default setting).


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Problem is present in both Windows and Linux versions. Tried 6.3.1 and 6.3.2 on Linux, 6.3.2 on Windows. Exporting to PDF results in the PDF having the same problem.
Comment 1 Xisco Faulí 2019-10-04 13:44:32 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Angelos Skembris 2019-10-04 13:52:24 UTC
Created attachment 154760 [details]
Document with two words in increased character spacing. One has pair kerning enabled, the other one does not.
Comment 3 Dieter Praas 2019-10-08 15:45:57 UTC
I'm not an expert, but I think, it's because ligatures are enabled. If you disable them (just type Calibri:-liga in font combobox) you recieve the desired result.

So for me not a bug, but I agree, that documentation about ligatures could be improved (I couldn't find anything about it).

=> RESOLVED NOTABUG

If you disagree, please change it back to UNCONFIRMED with a short reasoning.
Comment 4 Angelos Skembris 2019-10-08 16:37:12 UTC

*** This bug has been marked as a duplicate of bug 66819 ***
Comment 5 Angelos Skembris 2019-10-08 16:39:55 UTC
(In reply to Dieter Praas from comment #3)
> I'm not an expert, but I think, it's because ligatures are enabled. If you
> disable them (just type Calibri:-liga in font combobox) you recieve the
> desired result.
> 
> So for me not a bug, but I agree, that documentation about ligatures could
> be improved (I couldn't find anything about it).
> 
> => RESOLVED NOTABUG
> 
> If you disagree, please change it back to UNCONFIRMED with a short reasoning.

Thanks for looking into this, Dieter. From your comments, I saw there already is a bug report on this, so I marked it as a duplicate.