Bug 127923 - Sizes of two pictures –probably identical– inserted into a document differ from each other
Summary: Sizes of two pictures –probably identical– inserted into a document differ fr...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-02 10:51 UTC by ricky.tigg
Modified: 2019-10-11 09:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Steps' illustrations (120.00 KB, application/x-tar)
2019-10-02 10:54 UTC, ricky.tigg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ricky.tigg 2019-10-02 10:51:58 UTC
Description:
Sizes of two pictures –an original and an unchanged copy of that original– inserted into a document differ from each other.

Steps to Reproduce:
1. Take a screenshot (gnome-screenshot_sample.pngt); gnome-screenshot was used;
2. Make a copy of that screenshot (gnome-screenshot_sample_copy_GIMP.png);
3. Open step-2's screenshot file in GIMP. No changes;
4. Export it keeping its current name and using default settings (GIMP_export_settings.png);
5. Drag files from steps 1 and 4 into a document, respectively left-sided and right-sided.

Actual Results:
File gnome-screenshot_sample_copy_GIMP.png is exhibited in a smaller size than the original gnome-screenshot_sample.png. See Libreoffice_writer_drop-in_samples.png.

Expected Results:
Equal sizes.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.2.2; Build ID: 6.3.2.2-1.fc31; CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 ricky.tigg 2019-10-02 10:54:18 UTC
Created attachment 154696 [details]
Steps' illustrations
Comment 2 Dieter 2019-10-09 12:34:10 UTC
Ricky, I took a look at you files.

Opening with IrfanView:
Size of gnome-screenshot_sample.png: 3,09 x 1,49 cm
Size of gnome-screenshot_sample_copy_GIMP.png: 3,61 x 1,74

So for me it doesn't look like an unchanged copy. Therefore for me NOTABUG or NOTOURBUG.
Comment 3 ricky.tigg 2019-10-10 08:54:11 UTC
Pertinent observation. I assumed supplied sample pictures were probably identical according to their appearance alone, which could not be a relevant approach.
Comment 4 Dieter 2019-10-10 10:35:42 UTC
(In reply to ricky.tigg from comment #3)
> Pertinent observation. I assumed supplied sample pictures were probably
> identical according to their appearance alone, which could not be a relevant
> approach.

So what do you propose?
Comment 5 ricky.tigg 2019-10-10 14:14:15 UTC
Investigate on GIMP's side since it may be an issue and close here as NOTOURBUG
Comment 6 ricky.tigg 2019-10-11 09:43:02 UTC
Reporter at https://gitlab.gnome.org/GNOME/gimp/issues/4068