Bug 127932 - Printing progress dialog briefly shows the total page numbers multiplied by ten in the beginning
Summary: Printing progress dialog briefly shows the total page numbers multiplied by t...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All Windows (All)
: medium trivial
Assignee: Juergen Funk (CIB)
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:6.4.7
Keywords: bibisected, bisected, needsDevEval
: 131002 133224 134616 134673 139346 139378 (view as bug list)
Depends on:
Blocks: File-Progress-Bar
  Show dependency treegraph
 
Reported: 2019-10-02 16:51 UTC by Buovjaga
Modified: 2022-04-08 07:11 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video showing the behaviour (262.21 KB, video/x-matroska)
2019-10-02 16:51 UTC, Buovjaga
Details
Video showing the behaviour on Windows 10 (2.37 MB, video/x-ms-wmv)
2019-12-17 12:42 UTC, Marco A.G.Pinto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2019-10-02 16:51:11 UTC
Created attachment 154713 [details]
Video showing the behaviour

1. Print something (just PDF is fine)
2. Observe closely the printing progress dialog

If you are printing 4 pages, the dialog will briefly show the total as 40 pages.

Bibisected with win32-6.3 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/66bfaa01486891627b0748c4ba7b8d86e0fdc439%5E!/
but this is just revealing the truth and cannot be called a regression.

Cloph pointed to this bit:
https://gerrit.libreoffice.org/plugins/gitiles/core/+/master/vcl/source/window/printdlg.cxx#2175

//just multiply largest value by 10 and take the width of that string as
//the max size we will want

Reported by Arno83 on IRC. In the video you see the behaviour at 7-8 sec.
Comment 1 BogdanB 2019-12-17 12:33:50 UTC
Confirm it on
Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ro-RO (ro_RO); UI-Language: en-US
Calc: threaded
Comment 2 BogdanB 2019-12-17 12:35:22 UTC
It's a zero after any number of pages I print.
Comment 3 Marco A.G.Pinto 2019-12-17 12:42:37 UTC
Created attachment 156619 [details]
Video showing the behaviour on Windows 10
Comment 4 Jernej Simončič 2020-02-05 10:19:32 UTC
Still happening in 6.4.0.3, gave me a bit of a fright when I wanted to print a single page from a 10-page document, and it showed "Page 10 of 10" at first.

Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: privzeta; VCL: win; 
Locale: sl-SI (sl_SI); Jezik vmesnika: sl-SI
Calc: threaded
Comment 5 BogdanB 2020-02-05 19:05:17 UTC Comment hidden (obsolete)
Comment 6 BogdanB 2020-05-23 05:42:34 UTC
*** Bug 131002 has been marked as a duplicate of this bug. ***
Comment 7 Timur 2020-07-07 15:47:41 UTC
*** Bug 134616 has been marked as a duplicate of this bug. ***
Comment 8 Timur 2020-07-07 15:47:58 UTC
*** Bug 133224 has been marked as a duplicate of this bug. ***
Comment 9 Oliver Brinzing 2020-07-10 05:00:58 UTC
*** Bug 134673 has been marked as a duplicate of this bug. ***
Comment 10 Juergen Funk (CIB) 2020-09-08 06:42:57 UTC
Patch here https://gerrit.libreoffice.org/c/core/+/102031
Comment 11 BogdanB 2020-09-08 06:50:06 UTC
Glad to see progress here, it is very annoing.
Comment 12 Commit Notification 2020-09-08 11:40:56 UTC
Juergen Funk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/63bf8f042abe3c0f6989f6763d13f5389182b816

tdf#127932 fix wrong page number in print progress

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-09-09 07:25:51 UTC
Juergen Funk committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/9c843ca8659bc06694f44b5641186716d1428de6

tdf#127932 fix wrong page number in print progress

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 BogdanB 2020-09-09 08:43:47 UTC
Juergen Funk, I think you should change the status of the bug to be  resolved.
Comment 15 Juergen Funk (CIB) 2020-09-09 09:16:51 UTC
Okay, done
Comment 16 Buovjaga 2020-09-09 11:59:08 UTC
Seems to be working as expected now, thanks!

Version: 7.1.0.0.alpha0+ (x64)
Build ID: e00e2be30436b636d93f8852bb6af44972638a7c
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 17 Timur 2020-09-09 12:01:27 UTC
Please backport to 6.4.
Comment 18 Juergen Funk (CIB) 2020-09-10 05:16:38 UTC
6.4 would be done, but the tb77 has an issue
Comment 19 Commit Notification 2020-09-10 10:12:03 UTC
Juergen Funk committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/72c1c84e14ffc8127f24930066220e7c7b28a970

tdf#127932 fix wrong page number in print progress

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Timur 2021-01-03 14:00:48 UTC
*** Bug 139378 has been marked as a duplicate of this bug. ***
Comment 21 Timur 2021-03-15 12:35:28 UTC
*** Bug 139346 has been marked as a duplicate of this bug. ***