Bug 127934 - Make Cell Format dialog HIG conform
Summary: Make Cell Format dialog HIG conform
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Cell-Format-Dialog
  Show dependency treegraph
 
Reported: 2019-10-02 19:13 UTC by andreas_k
Modified: 2021-12-03 04:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Cell Format 01 (153.28 KB, image/png)
2019-10-02 19:13 UTC, andreas_k
Details
Screenshot with the patch applied (56.45 KB, image/png)
2019-10-10 09:44 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-10-02 19:13:03 UTC
Created attachment 154715 [details]
Cell Format 01

Top: Master
Bottm: Proposal

Tab Numbers:
- Language Section is in Font tab so I don't see an reason to have it at Numbers tab too.
- Options are related to Category -> Format so it is left to Format (also at Excel)
- Preview is on bottom like in Font tab (next one)
- Format code (I don't know what are the 3 buttons and the User-defined label for)

Tab Alignment:
- Text Alignment items in different rows (like in Excel and ordinary in most LibO groups)
- text Orientation labels and options left and "preview" right, cause preview is ordinary right
- Text direction I don't know if this should be visible cause ordinary LTR <-> RTL options are only visible when selected in global LibO options dialog.
Comment 1 Heiko Tietze 2019-10-08 12:08:15 UTC
Missing Language at Numbers tab (affects the list of formats, see Hebrew for example). Alternative layout would be to show the preview on the right column and options below the lists.

Regarding Alignment, the Indent(ation) relates to the Horizontal alignment (only for Left). Would place it next to this dropdown. No hard feelings about the rest.
Comment 2 Cor Nouws 2019-10-09 19:00:31 UTC
Thanks - looks good in general. Apart - as Heiko said - skipping language. That definitely is needed here.
Comment 3 Heiko Tietze 2019-10-10 07:40:06 UTC
UX input given, removing the keyword.
Comment 4 Heiko Tietze 2019-10-10 09:44:09 UTC
Created attachment 154894 [details]
Screenshot with the patch applied

Commenting on Gerrit...
Comment 5 Thomas Lendo 2019-10-10 20:05:44 UTC
Was the Numbers tab also changed now?

Alignment tab:
I don't like that the text alignment drop-down buttons are so long.
And I also don't like that the text orientation degree +/- field and the degree wheel are visually detached. They must stay together and it's not only a preview image, it can be used to change the degrees by mouse.
Comment 6 Commit Notification 2019-10-18 09:55:58 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9ab51f7aead713516b7e9a30aa64190d80517cbc

tdf#127934 Make Cell Format Align Dialog HIG conform

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-12-03 10:54:00 UTC
A polite ping to Andreas Kainz:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks
Comment 8 QA Administrators 2021-12-03 04:22:08 UTC
Dear andreas_k,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug