Download it now!
Bug 127939 - iOS 13: not possible to close presentation when in full screen presentation mode
Summary: iOS 13: not possible to close presentation when in full screen presentation mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: iOS Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other iOS
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.3.5 target:6.4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-03 07:49 UTC by Nicolas Christener
Modified: 2019-12-05 22:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Christener 2019-10-03 07:49:31 UTC
Description:
It's possible to start a presentation in fullscreen mode on iOS.

However there is no user visible way (at least for me) to close the fullscreen presentation mode in iOS 13.

In iOS 12.x a fullscreen presentation could be closed with a "swip up". 

Steps to Reproduce:
1. Open a presentation in impress on iOS
2. Start fullscreen presentation
3. Try to stop/close the presentation to go back in to the edit mode

Actual Results:
There is no user visible way to stop/close a fullscreen presentation.

Expected Results:
E.g. swipping up should stop/close the presentation.


Reproducible: Always


User Profile Reset: No



Additional Info:
This is a new issue in iOS 13, it worked in iOS 12.x
Comment 1 Xisco Faulí 2019-10-03 12:12:25 UTC
Moving to NEW as agreed in the ESC meeting
Comment 2 Tor Lillqvist 2019-10-23 13:14:28 UTC
Seems to be caused by a bug or misfeature in iOS 13: The WebKit software identifies itself as a Macintosh, not an iOS device. See https://forums.developer.apple.com/thread/119186 . Out slideshow JavaScript code uses the navigator.userAgent string to determine whether to set up the iOS-specific touch gesture recognizers.
Comment 4 Tor Lillqvist 2019-10-23 15:28:06 UTC
Fix in https://gerrit.libreoffice.org/#/c/81404/
Comment 5 Nicolas Christener 2019-10-31 13:05:56 UTC
Tested with 4.1.69.

I think this issue can be closed now.

Thanks a lot to the Collabora Team and especially to Tor for fixing this!
Comment 6 Commit Notification 2019-11-27 12:41:35 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8012a200d1a7c5cd1b64a147ca6899fb8863ce8b

tdf#127939: Make slideshow touch input work properly again on iOS 13

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-12-05 13:34:16 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/d1b7271cd7e13c0243c359bd8f66351a1495f51c

tdf#127939: Make slideshow touch input work properly again on iOS 13

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-12-05 22:24:07 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/662f8d687a56d01e8b192aefdeed4051102d19e4

tdf#127939: Make slideshow touch input work properly again on iOS 13

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.