Download it now!
Bug 127970 - Writer Enhancement Request - Remember last Edited Position
Summary: Writer Enhancement Request - Remember last Edited Position
Status: RESOLVED DUPLICATE of bug 92821
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-05 02:33 UTC by Paul Temple
Modified: 2020-02-19 09:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Unopened icon giving access to window with "go to last edit" option (57.92 KB, image/jpeg)
2019-10-05 02:36 UTC, Paul Temple
Details
Window (open after clicking on icon) offering option "go to last edited position" (88.30 KB, image/jpeg)
2019-10-05 02:38 UTC, Paul Temple
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Temple 2019-10-05 02:33:49 UTC
Description:
This is independent of versions, though I'm using  6.3.2.2 (x64).

I recently migrated from WPS Writer, and find OpenOffice far better (so far). However, one function I miss is that WPS Writer remembers the last edited position in a document. In WPS Writer, If I open a previously edited document, I can simply click a symbol at top right of the editable page (see first attachment, enhance1.jpg) and it opens a small window that allows me to click on two options; go to last editing position OR go to previous position (see first attachment, enhance2.jpg) . This small icon is available at all times that the document is open for editing and greatly speeds up moving around a large document when editing.

This would be a much appreciated function if similar could be available in OpenOffice.

Actual Results:
The function doesn't exist so there is no actual result

Expected Results:
If you create the enhancement, if I click on "go to last edited position" the cursor will go to the last edited position.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Paul Temple 2019-10-05 02:36:43 UTC
Created attachment 154766 [details]
Unopened icon giving access to window with "go to last edit" option
Comment 2 Paul Temple 2019-10-05 02:38:20 UTC
Created attachment 154767 [details]
Window (open after clicking on icon) offering option "go to last edited position"
Comment 3 V Stuart Foote 2019-10-05 04:34:43 UTC
Well as you are using LibreOffice you might want to look a little closer.

If you open Tools -> Options and in the User Data panel make any entry into the 'First/Last/initials' field when you reopen a saved document it will be positioned where you last edited it.

Having an entry in the user will result in an 'Edit view' stanza containing that data being written into the document on saving. Then when reopening the document (when the last user matches your user identity) that position will be read from the document which will reposition.

While editing, <Shift>+F5 will position you back to that last edited position (as set when document was saved). 

And, as you edit--the 'edit view' location will be advanced to the cursor position  when you save the document as the document is saved. Closing and reopening the document would reopen to that position -- the new 'Edit view'

You can also place the Sidebar Navigator in to 'Reminder' mode, and use the 'Navigator' tool bar or the Sidebar Navigator deck's Next / Previous buttons to reposition while actively editing the document. Or with Navigator in 'Bookmark' mode, drop bookmarks and navigate with those. The 'Bookmarks' will carry from session to session, the 'Reminders' will not.

And, bug 92821 is open to automatically drop the markers and link the <Shift>+F5 shortcut to navigate to each of the last five edit positions of an active editing session.

*** This bug has been marked as a duplicate of bug 92821 ***
Comment 4 minthrani 2019-10-05 05:40:16 UTC Comment hidden (spam)
Comment 5 Nora 2020-02-19 09:09:19 UTC Comment hidden (spam)