Bug 127997 - Systematic crash after 30 to 60 seconds on MacOS High Sierra - fresh installation
Summary: Systematic crash after 30 to 60 seconds on MacOS High Sierra - fresh installa...
Status: RESOLVED DUPLICATE of bug 127619
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-07 10:13 UTC by andre78ch
Modified: 2019-10-07 15:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andre78ch 2019-10-07 10:13:42 UTC
Description:
Steps: 

- All traces of LO suppressed before reinstall (removed: ~/Library/Application Support/LibreOffice, ~/Library/Saved Application State/org.libreoffice.script.savedState, /private/var/folders/.../.../C/org.libreoffice.script etc.)
- FRESH INSTALL of Libre Office 6.3.2 
- Open LibreOffice
- Do anything (create new Writer or Calc document, start writing, go into menu, does not matter) 
- Crashes after 30 to 60 seconds. 

Happens also in Safe mode.


Mac bug report:

Process:               soffice [26916]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            org.libreoffice.script
Version:               6.3.2002 (6.3.2002)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [26916]
User ID:               502

Date/Time:             2019-10-07 11:27:22.281 +0200
OS Version:            Mac OS X 10.13.6 (17G8037)
Report Version:        12
Bridge OS Version:     3.0 (14Y901)
Anonymous UUID:        29DF5ED0-952B-C746-CBE6-3FFE8AD7E284

Sleep/Wake UUID:       6B6D305E-8CFD-4316-9528-EEBB8A336507

Time Awake Since Boot: 110000 seconds
Time Since Wake:       2500 seconds

System Integrity Protection: enabled

Crashed Thread:        7  UpdateCheckThread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000010
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x10:
--> 
    __TEXT                 0000000108e33000-0000000108e34000 [    4K] r-x/rwx SM=COW  /Applications/LibreOffice.app/Contents/MacOS/soffice

Application Specific Information:
abort() called
...

Thread 7 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x000070000fe0a000  rcx: 0x000070000fe07df8  rdx: 0x0000000000000000
  rdi: 0x000000000000da5b  rsi: 0x0000000000000006  rbp: 0x000070000fe07e30  rsp: 0x000070000fe07df8
   r8: 0x00007fff9b4239e8   r9: 0xffffffff00000000  r10: 0x0000000000000000  r11: 0x0000000000000206
  r12: 0x000000000000da5b  r13: 0x00007fd22ab0d660  r14: 0x0000000000000006  r15: 0x000000000000002d
  rip: 0x00007fff62b4bb66  rfl: 0x0000000000000206  cr2: 0x00007fff9b421168
  
Logical CPU:     0
Error Code:      0x02000148
Trap Number:     133


External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 75654
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=543.6M resident=0K(0%) swapped_out_or_unallocated=543.6M(100%)
Writable regions: Total=550.3M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=550.3M(100%)
 
                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Accelerate framework               384K        3 
Activity Tracing                   256K        2 
CG backing stores                 66.4M       13 
CG image                          13.4M       12 
CG raster data                    2932K       23 
CoreAnimation                      212K        8 
CoreGraphics                         8K        2 
CoreImage                           28K        4 
CoreUI image data                 3264K       24 
CoreUI image file                  340K        6 
Dispatch continuations            16.0M        2 
Foundation                          36K        3 
Kernel Alloc Once                    8K        2 
MALLOC                           400.2M      156 
MALLOC guard page                   48K        9 
MALLOC_LARGE (reserved)           25.2M        4         reserved VM address space (unallocated)
Memory Tag 242                      12K        2 
Memory Tag 251                      12K        2 
SQLite page cache                  448K        3 
STACK GUARD                       56.0M       10 
Stack                             12.1M       12 
VM_ALLOCATE                       12.6M      548 
__DATA                            36.0M      414 
__FONT_DATA                          4K        2 
__GLSLBUILTINS                    2588K        2 
__LINKEDIT                       243.7M      141 
__TEXT                           299.9M      390 
__UNICODE                          560K        2 
mapped file                        1.0G      705 
shared memory                     3300K       27 
===========                     =======  ======= 
TOTAL                              2.2G     2503 
TOTAL, minus reserved VM space     2.2G     2503 

Model: MacBookPro13,3, BootROM 259.71.1.0.0, 4 processors, Intel Core i7, 2.7 GHz, 16 GB, SMC 2.38f7
Graphics: Intel HD Graphics 530, Intel HD Graphics 530, Built-In
Graphics: Radeon Pro 455, AMD Radeon Pro 455, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320

java version "1.8.0_65"
Java(TM) SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

Steps to Reproduce:
1. Uninstall LO Fully (remove not only app, but also: ~/Library/Application Support/LibreOffice, ~/Library/Saved Application State/org.libreoffice.script.savedState, /private/var/folders/.../.../C/org.libreoffice.script etc.)
2. Download the newest version (dmg).
3. FRESH INSTALL of Libre Office 6.3.2 
4. Open LibreOffice (the start screen opens and proposes to create a document)
5. Do anything (create new Writer or Calc document and start writing, go into menu, it does not matter what you do) 
6. Crashes after 30 to 60 seconds. 

Happens also in Safe mode.

Actual Results:
Crashes after 30 to 60 seconds. 

Expected Results:
Application working.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 andre78ch 2019-10-07 12:26:37 UTC
Also crashes when starting from the terminal:

Terminal command executed:

/Applications/LibreOffice.app/Contents/MacOS/soffice

Libreoffice opens 

and crashes after 30 seconds. 

This message appears in terminal:

(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed
Comment 2 V Stuart Foote 2019-10-07 13:28:18 UTC
See https://bugs.documentfoundation.org/show_bug.cgi?id=127619#c17 for work around.

*** This bug has been marked as a duplicate of bug 127619 ***
Comment 3 andre78ch 2019-10-07 15:01:48 UTC
@V Stuart Foote : Turnin off autoupdate as fast as possible on LO startup, applying the change and restarting LO solved this indeed. Many thanks for the workaround.