Bug Hunting Session
Bug 128013 - Crash when linking an odp file
Summary: Crash when linking an odp file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: highest critical
Assignee: Julien Nabet
URL:
Whiteboard: target:6.4.0 target:6.3.3 target:6.2....
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2019-10-08 09:21 UTC by Jean-Sebastien Bevilacqua
Modified: 2019-10-10 06:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SfxDispatcher::ExecuteList(unsigned short,SfxCallMode,std::initializer_list<SfxPoolItem const *>,std::initializer_list<SfxPoolItem const *>)"]


Attachments
test1 file (25.16 KB, application/vnd.oasis.opendocument.presentation)
2019-10-08 09:22 UTC, Jean-Sebastien Bevilacqua
Details
test 2 file (12.02 KB, application/vnd.oasis.opendocument.presentation)
2019-10-08 09:22 UTC, Jean-Sebastien Bevilacqua
Details
sample document with a link in text (12.08 KB, application/vnd.oasis.opendocument.presentation)
2019-10-08 11:30 UTC, Xisco Faulí
Details
bt with debug symbols (13.70 KB, text/plain)
2019-10-08 20:42 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sebastien Bevilacqua 2019-10-08 09:21:52 UTC
Hello,

I found a crash in a specific situation.

Here the step to reproduce it:

1. Open the joined Test1.odp file
2. Click on the blue circle, it will open the Test2.odp file
3. Come back on Test1.odp and click again on the circle

LibreOffice will crash.
I did a first bisection and here the result:

6.0.0.1 -> OK
6.1.0.1 -> OK
6.1.6.3 -> OK
6.2.0.0.alpha1 -> Crash
6.2.0.1 -> Crash
6.2.7.1 -> Crash
6.3.2.2 -> Crash

The problem appears from the 6.2 version and is still here.

Thanks,
Jean-Sébastien
Comment 1 Jean-Sebastien Bevilacqua 2019-10-08 09:22:09 UTC
Created attachment 154821 [details]
test1 file
Comment 2 Jean-Sebastien Bevilacqua 2019-10-08 09:22:33 UTC
Created attachment 154822 [details]
test 2 file
Comment 3 Xisco Faulí 2019-10-08 10:57:12 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3c86ffd8ded628e6f2b4187948a1b1056f6a0f56

author	Jim Raykowski <raykowj@gmail.com>	2018-07-12 15:22:39 -0800
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2018-09-05 11:34:22 +0200
commit	3c86ffd8ded628e6f2b4187948a1b1056f6a0f56 (patch)
tree	d6b2fcaa83d4dfd803d81bb557d835a68226eb45
parent	a14088e2822f6018f19677705a74d2f37d0d0431 (diff)
tdf#118696 impress navigator: zoom slide/slide object on select

Bisected with: bibisect-linux64-6.2

Adding Cc: to Jim Raykowski
Comment 4 Xisco Faulí 2019-10-08 11:06:44 UTC
In master it can only be reproduced in slideshow mode due to bug 128017
Comment 5 Xisco Faulí 2019-10-08 11:30:15 UTC
Created attachment 154828 [details]
sample document with a link in text
Comment 6 Julien Nabet 2019-10-08 20:42:28 UTC
Created attachment 154847 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 7 Julien Nabet 2019-10-08 20:50:13 UTC
I submitted this patch on gerrit:
https://gerrit.libreoffice.org/#/c/80500/
Comment 8 Commit Notification 2019-10-09 05:56:14 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1dc4c8266d45eb2f5c3de303eaa9233e3b52f058

tdf#128013: fix Crash when linking an odp file

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2019-10-09 06:54:08 UTC
Patch for 6.3 on gerrit review here:
https://gerrit.libreoffice.org/#/c/80506/
Comment 10 Commit Notification 2019-10-09 10:22:49 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/30db36c3afcd796fe15a06869cd43ef74c3ffc36

tdf#128013: fix Crash when linking an odp file

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-10-09 18:06:14 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/60f604bd06418c2a521e0b7b018c0edf7e65e9c4

tdf#128013: fix Crash when linking an odp file

It will be available in 6.2.9.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2019-10-09 19:29:39 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: ae7b26246ec03dbff3d43a0dc04fd9ffd2cd0809
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Julien Nabet, thanks for fixing this issue!
Comment 13 Commit Notification 2019-10-10 06:15:12 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-8":

https://git.libreoffice.org/core/commit/10254887286aeb0df54b531a689eae387bbe1f62

tdf#128013: fix Crash when linking an odp file

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.