Download it now!
Bug 128028 - SPELL CHECKING: English Word incorrectly underlined, but appears as synonym.
Summary: SPELL CHECKING: English Word incorrectly underlined, but appears as synonym.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2019-10-08 14:50 UTC by Dylan Risso
Modified: 2019-11-21 14:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot of the error in version 6.3.2.2 (148.21 KB, image/jpeg)
2019-10-15 18:45 UTC, Dylan Risso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dylan Risso 2019-10-08 14:50:47 UTC
Description:
The word 'eery' is underlined in red, despite if being offered as a Thesaurus alternative to 'eerie'. Both spellings are usually indicated as acceptable, although 'eerie' is the more correct spelling of the word.

Steps to Reproduce:
1. Type 'eery' in LibreOffice Writer.
2. Notice the red underline.
3. Highlight the word, and open the Thesaurus.
4. Select 'eerie' from the alternatives list, and 'eery' will pop up as a valid replacement.

Actual Results:
Eery was underlined as incorrect, yet still offered as a replacement for 'eerie'.

Expected Results:
It should accept both spellings.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no

Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 1 Durgapriyanka 2019-10-11 13:59:04 UTC
Thank you for reporting the bug. I cannot reproduce the bug in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Samson 2019-10-14 14:16:14 UTC
Hi,
I was able to recreate bug using 
Version: 6.2.7.1 (x64)
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
Comment 3 Dylan Risso 2019-10-14 15:20:14 UTC
I suppose it has already been fixed in the newest version then.
Comment 4 Dieter 2019-10-14 18:26:41 UTC
Dylan, could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 5 Dylan Risso 2019-10-15 18:45:13 UTC
Created attachment 155024 [details]
A screenshot of the error in version 6.3.2.2
Comment 6 Dylan Risso 2019-10-15 18:46:00 UTC
The issue persists in the latest release.
Comment 7 Dieter 2019-10-15 19:04:18 UTC
I confirm the behaviour with

Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

but I'm not sure, if this is really a bug. I won't expect that dictionary knows every word.

Additional information: Dylan, you set yourself to Assignee. That means, that you you are going to fix that bug. If this is the case, it is O. K. If not, please remove yourself.
Comment 8 Xisco Faulí 2019-11-21 13:19:33 UTC
@Marco, any opinion here ?
Comment 9 Marco A.G.Pinto 2019-11-21 13:52:44 UTC
Yes, the word is missing in the GB speller at least:
https://www.collinsdictionary.com/dictionary/english/eery

I have just added:
51217) eery

I am not sure if it is also missing in US+CA+AU since they are maintained by Kevin Atkinson.

The English spellers are only merged into master by me twice a year: on May and November, and I have already committed November's.

This means that only within 6 months the word will be integrated, unless the users download the English Dictionaries extension manually on 1-JAN-2020:
https://extensions.libreoffice.org/extensions/english-dictionaries

Thanks!
Comment 10 Marco A.G.Pinto 2019-11-21 14:48:15 UTC
Better yet, you can always check the words in the English variants:
https://github.com/marcoagpinto/aoo-mozilla-en-dict

Each variant has a folder in GitHub and inside them it can be seen the full wordlist along with the other dictionary files.