Bug Hunting Session
Bug 128052 - Cannot use Highlight Color (Yellow) with keyboard shortcut
Summary: Cannot use Highlight Color (Yellow) with keyboard shortcut
Status: RESOLVED DUPLICATE of bug 34804
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2019-10-09 14:21 UTC by Thiago Sueto
Modified: 2019-10-10 12:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Sueto 2019-10-09 14:21:31 UTC
Description:
Even after setting a keyboard shortcut to Highlight Color, I cannot highlight text with the keyboard shortcut.

Steps to Reproduce:
1.Assign keyboard shortcut to Highlight Color
2.Try highlighting any selected text

Actual Results:
No highlighting occurs

Expected Results:
Text should be highlighted


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.1.2
Build ID: 1:6.3.1~rc2-0ubuntu0.19.04.1~lo1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: en-US (C); UI-Language: en-US
Calc: threaded
Comment 1 Dieter Praas 2019-10-10 07:10:21 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 460908269972fd1f89312a1e62897ed1503e9e98
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-30_09:18:03
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

There are two "Highlight Color" function and both doesn't work.
Comment 2 Heiko Tietze 2019-10-10 08:05:17 UTC
We have 
* .uno:CharacterBackgroundPattern/SID_ATTR_BRUSH_CHAR (GenericCommand)
* .uno:CharBackColor/SID_ATTR_CHAR_BACK_COLOR (Generic) and 
* .uno:BackColor/SID_ATTR_CHAR_COLOR_BACKGROUND (Writer) 

all labeled "Highlight Color". And all are defined with "MenuConfig = FALSE" so I would expect them to not show up in the customization. AM I wrong, Maxim?
Comment 3 Maxim Monastirsky 2019-10-10 12:19:56 UTC
(In reply to Heiko Tietze from comment #2)
> We have 
> * .uno:CharacterBackgroundPattern/SID_ATTR_BRUSH_CHAR (GenericCommand)
> * .uno:CharBackColor/SID_ATTR_CHAR_BACK_COLOR (Generic) and 
> * .uno:BackColor/SID_ATTR_CHAR_COLOR_BACKGROUND (Writer) 
> 
> all labeled "Highlight Color". And all are defined with "MenuConfig = FALSE"
> so I would expect them to not show up in the customization. AM I wrong,
> Maxim?
As of now, you need to set all of AccelConfig, MenuConfig, and ToolBoxConfig to FALSE. See Bug 112620.
Comment 4 Maxim Monastirsky 2019-10-10 12:20:39 UTC
And the bug itself is a duplicate of Bug 34804.

*** This bug has been marked as a duplicate of bug 34804 ***