Bug Hunting Session
Bug 128061 - Multi-selecting text boxes within a frame via CTRL not possible
Summary: Multi-selecting text boxes within a frame via CTRL not possible
Status: RESOLVED DUPLICATE of bug 121967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Textbox
  Show dependency treegraph
 
Reported: 2019-10-09 23:58 UTC by BottleOnTheGround
Modified: 2019-10-10 14:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BottleOnTheGround 2019-10-09 23:58:33 UTC
This might be an enhancement request, depending on your view. But since multiselection is common for anything related to drawing, I interpret this behaviour as a bug.

Reproduce:
 1. Create Frame
 2. Anchor it "As Character"
 3. Add 3 text boxes (write a single letter in each box)
 4. Select one text box
 5. Press and hold ctrl and left-click on another text box
 6. 
  Expected: Both text boxes become selected.
  Actual: Only second text box becomes selected (selection of first text box vanishes).
Comment 1 Dieter Praas 2019-10-10 12:13:16 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 460908269972fd1f89312a1e62897ed1503e9e98
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-30_09:18:03
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

and also with

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group

But I'm not sure, if this is a bug, an enhancement request or simply the expected result. => cc: Design Team

Additional information: Also text boxes outside a frame can't be multi-selected
Comment 2 V Stuart Foote 2019-10-10 14:42:51 UTC
In LibreOffice multi-selection is done with <Shift>+click; which works correctly for the use case of OP.

Dupe to bug 121967 for enhancement request to enable optional use of <Ctrl>+click for multi-selection.

*** This bug has been marked as a duplicate of bug 121967 ***