Bug 128072 - Libreoffice Calc autofilter is getting stuck for minutes when typing in the search box, only if input data is diversified.
Summary: Libreoffice Calc autofilter is getting stuck for minutes when typing in the s...
Status: RESOLVED DUPLICATE of bug 122419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ods, filter:xlsx, perf
Depends on:
Blocks: AutoFilter
  Show dependency treegraph
 
Reported: 2019-10-10 12:25 UTC by Arnaldo Pirrone
Modified: 2019-10-10 17:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaldo Pirrone 2019-10-10 12:25:19 UTC
Description:
When I open ods or xlsx files with ~35000 rows in Libreoffice Calc, and try to filter the input data from a column whose stored data is very diversified, the program gets stuck for a long time. I don't think this should happen. 

Steps to Reproduce:
1.Open an odt or xlsx file with 35000 rows and at least one column of diversified data.
2.Select the first row, then click autofilter on
3.Click on the arrow in the aforementioned column, and type something into the search box.

Actual Results:
The search algorithm gets stuck.

Expected Results:
The output data should appear fastly.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2019-10-10 17:13:52 UTC
looks like a duplicate of:

Bug 122419 - AutoFilter Search Freezes Calc in the Attached Spreadsheet

*** This bug has been marked as a duplicate of bug 122419 ***