Bug 128073 - CRASH: in SwIndex::SwIndex(SwIndexReg * const,long)
Summary: CRASH: in SwIndex::SwIndex(SwIndexReg * const,long)
Status: RESOLVED DUPLICATE of bug 132911
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Crash-Assert Undo-Redo
  Show dependency treegraph
 
Reported: 2019-10-10 12:27 UTC by Xisco Faulí
Modified: 2020-12-21 10:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SwIndex::SwIndex(SwIndexReg * const,long)"]
Regression By:


Attachments
gdb bt (14.67 KB, text/plain)
2019-10-10 19:51 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-10-10 12:27:03 UTC
Steps to reproduce:
1. Open attachment 139598 [details] from bug 115212
2. Select all
3. Cut
4. Paste 3 times
5. Undo 3 times

-> Repeat steps 4 and 5 until it crashes

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: ae7b26246ec03dbff3d43a0dc04fd9ffd2cd0809
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-10-10 12:31:38 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 2 Xisco Faulí 2019-10-10 12:37:41 UTC
and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9
Comment 3 Julien Nabet 2019-10-10 19:51:02 UTC
Created attachment 154912 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I got an assertion.

I attached console logs + bt
Comment 4 Julien Nabet 2019-10-10 19:52:07 UTC
I noticed this on console:
warn:legacy.osl:4143:4143:sw/source/core/doc/DocumentRedlineManager.cxx:95: redline table corrupted: empty redline

Michael: thought you might be interested in this one.
Comment 5 Telesto 2020-12-20 19:03:19 UTC
No crash for me
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 6 Xisco Faulí 2020-12-21 10:25:13 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=14bdbc36f0cf3913f6de10c746044b6aadf37095
Closing as duplicate of bug 132911

*** This bug has been marked as a duplicate of bug 132911 ***