Bug 128108 - 'File > Versions...' and then 'Compare' doesn't display deleted parts at the right place
Summary: 'File > Versions...' and then 'Compare' doesn't display deleted parts at the ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-10-12 13:30 UTC by Alex
Modified: 2019-10-15 17:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test example (53.07 KB, application/vnd.oasis.opendocument.text)
2019-10-12 13:31 UTC, Alex
Details
Another test file (21.15 KB, application/vnd.oasis.opendocument.text)
2019-10-14 17:53 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2019-10-12 13:30:28 UTC
Description:
I am testing the Version Management tool of LibreOffice Writer (LO version 6.0.3.7) and when comparing the latest version to previous ones, the deletions are not displayed at the right place in the document but seem to be displayed at the end only.

Steps to Reproduce:
1. While editing a document, click the menu 'File > Versions...' and then 'Save New Version'
2. Delete something somewhere before the end of the document 
3. Repeat step 1.
4. Compare the latest version with the previous version containing the deleted part ('File > Versions...' then select the version created at step 1 and click 'Compare'

Actual Results:
The deleted part is displayed at the end of the document in the Track Changes mode. 

Expected Results:
The deleted part should display at the position where it was in the document before the deletion.


Reproducible: Didn't try


User Profile Reset: No



Additional Info:
Please, see the attached 'Version management.odt' document containing a test example.
Comment 1 Alex 2019-10-12 13:31:04 UTC
Created attachment 154957 [details]
Test example
Comment 2 IM 2019-10-13 08:53:53 UTC
Thank you for reporting a bug, I can't reproduct it in:

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 460908269972fd1f89312a1e62897ed1503e9e98
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-30_09:18:03
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded
Comment 3 Xisco FaulĂ­ 2019-10-14 15:33:13 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 Alex 2019-10-14 17:53:19 UTC
Yes, I installed LO 6.3.2.2 from the PPA and I can reproduce the bug.
Here attached is another test file.
Comment 5 Alex 2019-10-14 17:53:55 UTC
Created attachment 155006 [details]
Another test file
Comment 6 Alex 2019-10-14 17:58:45 UTC
First, thank you all for your replies.

I notice that IM cannot reproduce the bug with his/her version of LO 6.3.2.2.
That is strange that I can reproduce the bug on my machine with an LO 6.3.2.2.

Here are the details of my version:
Version: 6.3.2.2
Build ID: 1:6.3.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

Could it be that the bug is in an external component that LO depends on, and that would not be up-to-date in my distribution?
Comment 7 QA Administrators 2019-10-15 02:30:24 UTC Comment hidden (obsolete)
Comment 8 raal 2019-10-15 17:34:59 UTC
Confirm with Version: 6.4.0.0.alpha0+
Build ID: 9b5dad13b56bdde7c40970351af3da3a2c3c9350
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

works in Version: 4.5.0.0.alpha0+
Build ID: 2851ce5afd0f37764cbbc2c2a9a63c7adc844311