Download it now!
Bug 128124 - Background color not shown in textbox control field, when border look is 3D or flat (Linux-only)
Summary: Background color not shown in textbox control field, when border look is 3D o...
Status: VERIFIED DUPLICATE of bug 136094
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: BASIC-Dialog-Designer GTK3
  Show dependency treegraph
 
Reported: 2019-10-13 21:14 UTC by elmau
Modified: 2020-09-21 05:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Backgroundcolor not shown in control textbox (10.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-10-13 21:14 UTC, elmau
Details
Background show correctly in Windows (5.18 KB, image/png)
2020-09-12 16:50 UTC, elmau
Details
Background not show in Linux (13.25 KB, image/png)
2020-09-12 16:51 UTC, elmau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elmau 2019-10-13 21:14:47 UTC
Created attachment 154980 [details]
Backgroundcolor not shown in control textbox

In standard dialog, the property Backgroundcolor in control textbox, only show when the property Border is: Without frame, but this property is: 3D llok or Flat, the back color not show.

Attach test file.
Comment 1 Buovjaga 2019-11-08 19:24:09 UTC
(In reply to elmau from comment #0)
> Created attachment 154980 [details]
> Backgroundcolor not show in control textbox
> 
> In standard dialog, the property Backgroundcolor in control textbox, only
> show when the property Border is: Without frame, but this property is: 3D
> llok or Flat, the back color not show.

How do we test with the file to see the bad result vs. good result? I tried fiddling with the control properties, but could not figure out what you mean.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 elmau 2019-11-08 19:52:54 UTC
Only open the file, that all.

The three controls should see background in yellow. Only shown in the first one.
Comment 3 Buovjaga 2019-11-08 20:43:21 UTC
Ok, so you click the button and observe input fields.
You can edit the dialog from Tools - Macros - Organize dialogs, expand the tree of the document and edit Dialog1.

This is not seen on Windows.

Would be interesting to hear from a macOS user.

Tested with 43all bibisect repo, the problem is already in last36onmaster. In oldest, I was unable to change macro security settings.
Comment 4 elmau 2019-11-08 21:30:59 UTC
For that, I set Linux (All)
Comment 5 elmau 2020-09-12 16:50:58 UTC
Created attachment 165420 [details]
Background show correctly in Windows
Comment 6 elmau 2020-09-12 16:51:25 UTC
Created attachment 165421 [details]
Background not show in Linux
Comment 7 elmau 2020-09-12 16:53:20 UTC
I attach two images. In Windows, the background color work fine in text box.

In Linux, only show if border type is Without frame

Test in LO 7
Comment 8 JJPalacios 2020-09-12 18:37:47 UTC
Confirmed on Linux versions Version: 6.4.5.2 (x64) and later

Test on:
 Version: 6.4.5.2 (x64)
 Version: 6.4.6.2 (x64)
 Version: 7.0.0.3 (x64)
Comment 9 Caolán McNamara 2020-09-18 07:57:10 UTC
caolanm->m.weghorn: Is this the same problem as bug 136094 and so is a duplicate of that ?
Comment 10 Michael Weghorn 2020-09-18 08:33:14 UTC
(In reply to Caolán McNamara from comment #9)
> caolanm->m.weghorn: Is this the same problem as bug 136094 and so is a
> duplicate of that ?

Yes, I can reproduce with LO from Debian testing, but it works fine with current master. Closing as duplicate.

Version: 7.1.0.0.alpha0+
Build ID: 007e6063931bd87d6ce15deb65b9adc823f74ce0
CPU threads: 12; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

*** This bug has been marked as a duplicate of bug 136094 ***
Comment 11 elmau 2020-09-18 17:36:33 UTC
I confirmed fix it in:

Version: 7.1.0.0.alpha0+
Build ID: f75581f73a24202f4c37f93e6233825ed2b50a4a
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Thanks.