Bug 128135 - UI GTK3: dialog Pivot Table Layout / properties is too high: section Source and Destination cannot be fully used
Summary: UI GTK3: dialog Pivot Table Layout / properties is too high: section Source a...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: needsUXEval
: 133124 (view as bug list)
Depends on:
Blocks: Pivot-Table GTK3-Dialog-High 135818
  Show dependency treegraph
 
Reported: 2019-10-14 07:47 UTC by Cor Nouws
Modified: 2020-11-18 15:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot dlg Pivot Table Layout too high (64.79 KB, image/png)
2019-10-14 07:47 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2019-10-14 07:47:24 UTC
Created attachment 154988 [details]
screen shot dlg Pivot Table Layout too high

On my 1366 X 768 screen, the dialog is too high to work with all elements in the section Source and Destination

Adding a screen shot

Seen in Version: 6.4.0.0.alpha0+
Build ID: 6131288f2a85d43ba21210e677648c9245793e52
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 m.a.riosv 2019-10-15 00:10:41 UTC
I can't repro with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: d744838991594eebe27acc4c7d9fb4579d654853
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-29_05:12:00
Locale: es-ES (es_ES); UI-Language: en-US Calc: threaded

But 1366x768 it's not the native format of my screen (1920x1080), selected on win10 screen configuration.
Comment 2 Roman Kuznetsov 2019-10-16 14:49:18 UTC
Cor, which DPI do you use for your screen?
Comment 3 Xisco Faulí 2019-11-21 13:18:45 UTC
Hi Cor,
I see your build is from 2019-07-23 22:25:57
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 4 Kevin Suo 2020-02-01 01:51:53 UTC
I reproduce this with:

Version: 7.0.0.0.alpha0+
Build ID: 62640556cca53ffa160456441db38899d6f885d5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); UI-Language: en-US
Calc: threaded

This is a Linux GTK3 only bug. It worked OK with SAL_USE_VCLPLUGIN=gtk (in versions before 6.3) and SAL_USE_VCLPLUGIN=GTK"gen".

Steps to reproduce:

1. Create a minimal spreadsheet file with the following contents:
a
1

2. Data > Pivot Table > Insert or Edit > OK, then click the "Source and Destination".
Comment 5 Roman Kuznetsov 2020-08-26 06:48:17 UTC
UX-team, your way out

ps: and I think I saw the same report already
Comment 6 Heiko Tietze 2020-09-08 11:20:19 UTC
Some mockups in bug 131654 (asking for a preview), and there is also bug 132183. Would prefer to merge the tickets but comments on the possible redesign are welcome anyway. 
And as a quick and dirty solution we could also make the page field control a dropdown to save vertical space.
Comment 7 Commit Notification 2020-09-09 22:49:56 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d435997f446941adaa76fe4b253946cd08861ffd

tdf#128135 update Pivot Table Layout to fit minimum height

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2020-09-10 09:30:18 UTC
*** Bug 133124 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Suo 2020-11-18 11:32:22 UTC
I can verify it is now working fine on master build, mark as FIXED.

Could someone do the change on libreoffice-7-0 branch as well?
Comment 10 Xisco Faulí 2020-11-18 11:41:39 UTC
(In reply to Kevin Suo from comment #9)
> I can verify it is now working fine on master build, mark as FIXED.
> 
> Could someone do the change on libreoffice-7-0 branch as well?

Done: https://gerrit.libreoffice.org/c/core/+/106002
Comment 11 Commit Notification 2020-11-18 14:48:27 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/6d9cc23a057ceccae1398e0c89596c5599404666

tdf#128135 update Pivot Table Layout to fit minimum height

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Cor Nouws 2020-11-18 15:20:59 UTC
thanks Andreas!