Download it now!
Bug 128144 - Tip of the day stops file-opening until dialog gets closed when opening multiple files at the same time
Summary: Tip of the day stops file-opening until dialog gets closed when opening multi...
Status: RESOLVED DUPLICATE of bug 127533
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-10-14 20:21 UTC by Telesto
Modified: 2019-10-15 08:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-10-14 20:21:25 UTC
Description:
Tip of the day stops file-opening until dialog gets closed when opening multiple files at the same time

Steps to Reproduce:
1. Having multiple files. Say attachment 143862 [details]
2. Launch LibreOffice to start center
3. File Open -> Select all files
4. Press Open
5. File opening stops after file 1

Forcing tip of the day
A) Tools -> Options -> Advanced -> Expert configuration
B) Search for tip of the day
C) Set LastTipOfTheDayShown to 1 

Actual Results:
File opening on hold until dialog closed

Expected Results:
Tip of the day should block file opening


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: c45d477b0a0038d9c25176cf7cff299e5ddf3a7a
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-09-30_05:06:55
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Mike Kaganski 2019-10-14 20:53:07 UTC
Note that if one opens About dialog (including from Start Center), it doesn't prevent opening documents behind it. Possibly worth looking which is different in their implementations.
Comment 2 Heiko Tietze 2019-10-15 06:37:52 UTC
Modal or not has been discussed in bug 127533 (with some other aspects around this topic in different tickets, eg. bug 127946) and it should be solved in master. Please verify.
Comment 3 Heiko Tietze 2019-10-15 07:59:55 UTC
(In reply to Heiko Tietze from comment #2)
> ... and it should be solved in master. 

Lost track, it's amodal in master so you cannot work while the dialog is open. Anyway, it's a duplicate of bug 127533.

*** This bug has been marked as a duplicate of bug 127533 ***
Comment 4 Mike Kaganski 2019-10-15 08:15:13 UTC
(In reply to Heiko Tietze from comment #3)
> (In reply to Heiko Tietze from comment #2)
> > ... and it should be solved in master. 
> 
> Lost track, it's amodal in master so you cannot work while the dialog is
> open. Anyway, it's a duplicate of bug 127533.

I'm unsure that these are the same (but of course, making it non-modal would also solve this): About box is *modal*, too (at least from UI PoV), but it still doesn't prevent opening files in background.