Download it now!
Bug 128217 - New version crashes on MAC
Summary: New version crashes on MAC
Status: RESOLVED DUPLICATE of bug 126409
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-17 15:57 UTC by Steve Glines
Modified: 2019-10-19 13:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen grab of Apple's reply to running Libra Office (32.12 KB, image/png)
2019-10-17 15:59 UTC, Steve Glines
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Glines 2019-10-17 15:57:54 UTC
Description:
Uploaded the last version of 6.2.8 and upon running it MACOS tells me it can't run it because Apple can't test it for bugs. "Apple cannot check for malicious software."

Steps to Reproduce:
1.Install
2. attempt to run
3.

Actual Results:
MacOS balked

Expected Results:
Open Main Screen


Reproducible: Always


User Profile Reset: No



Additional Info:
Latest Mac OS 10.15
Comment 1 Steve Glines 2019-10-17 15:59:27 UTC
Created attachment 155095 [details]
Screen grab of Apple's reply to running Libra Office
Comment 2 Alex Thurgood 2019-10-18 11:52:29 UTC
Not reproducible with

Version: 6.2.8.2
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
Threads CPU : 8; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded

on macOS 10.14.6

so this is specific to Catalina (yet another specific macOS 10.15 problem).
Comment 3 Alex Thurgood 2019-10-18 12:41:26 UTC
Not reproducible for me with

Version: 6.2.8.2
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 4; OS: Mac OS X 10.15; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

However, please see also bug 126409

You can work around the forced security restriction by opening the app bundle with a right mouse button click and holding the Shift key down while clicking on Open from the context menu.
Comment 4 Alex Thurgood 2019-10-18 12:41:43 UTC

*** This bug has been marked as a duplicate of bug 126409 ***
Comment 5 Christian Lohmaier 2019-10-19 13:15:15 UTC
FYI: for 6.2.x that is expected, 6.2 line is not notarized.

For 6.3.x (bug#126409) the installer /is/ notarized (and all verification tools as well as the notarization report itself shows no problem) but Catalina's gatekeeper still blocks installation for some reason (while on other versions of macOS you'll get the correct positive message (has been checked by Apple and no malicious software was found).

As there is no hint whatsoever why Catalina is not happy (but other versions are) - that bug won't be fixed for next release unfortunately.

To verify that your installer is genuine/from The Document Foundation, you can use codesign and spctl tools from Terminal:

For 6.3.x it should look something like this:

$ codesign -vvv --deep --strict ~/Desktop/LibreOffice.app/
[… individual elements all good …]
/Users/cloph/Desktop/LibreOffice.app/: valid on disk
/Users/cloph/Desktop/LibreOffice.app/: satisfies its Designated Requirement

$ spctl -vvv --assess --type exec ~/Desktop/LibreOffice.app/
/Users/cloph/Desktop/LibreOffice.app/: accepted
source=Notarized Developer ID
origin=Developer ID Application: The Document Foundation (7P5S3ZLCN7)


(replace ~/Desktop/LibreOffice.app with the path you copied LibreOffice to, for example /Applications/LibreOffice.app)