Bug 128260 - DOCX import issue with Left and Right hand Footers partially imported, example failure with 3-S Thesis Template.
Summary: DOCX import issue with Left and Right hand Footers partially imported, ex...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Header-Footer DOCX-TableofContents
  Show dependency treegraph
 
Reported: 2019-10-20 00:30 UTC by enyc
Modified: 2021-02-07 06:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
The winword DotX template file, contains sections and special page numbering configuration etc. (82.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.template)
2019-10-20 18:25 UTC, enyc
Details
The file as correctly rendered by WinWord-2010, exported as PDF. (400.93 KB, application/pdf)
2019-10-20 18:26 UTC, enyc
Details
The same file, imported into LO 6.3.2.2 and exported as hybrid PDF file by LO itself. (432.80 KB, application/pdf)
2019-10-20 18:27 UTC, enyc
Details
3-S Template, exported with automatic blank pages, by LO 6.4a1 Win7 32bit. (439.41 KB, application/pdf)
2019-11-01 20:48 UTC, enyc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description enyc 2019-10-20 00:30:46 UTC
Description:
Using the FormatMyThesis 3-S template dotx file, or files derived from said winword-template, does not import quite right in LibreOffice.

Specifically:-

(1) the Page-numbers fail after about page 4 of content (chapter 1 starts footnotes etc.)

(2) the Mechanic to make sure chapter etc. sections always start on an odd-numbered-page, is not working!.

Having communicated with the author, I am now creating this bug-report.
The 3 files of interest are:-

http://ec2.sheer.us/~enyc/noidx/FMT-3-S-Thesis-Template-v1.0.dotx
http://ec2.sheer.us/~enyc/noidx/FMT-3-S-Thesis-Template-v1.0_LO-6.3.2.2.pdf
http://ec2.sheer.us/~enyc/noidx/FMT-3-S-Thesis-Template-v1.0_WinWord-2010.pdf

So you can access the original dotx, and pdf export examles in any case.


Steps to Reproduce:
1. wget and open dotx file from above.
2. Observe page numbers are not working further down the document, as per the LO pdf above.
3. Also Observe the automatically-inserted blank pages are not coming out.

Actual Results:
As per above page numbers and automatic blank pages are not working right.

Expected Results:
I would expect a lot of "converted" page styles in a messy fashion, but at least a correctly working imported document.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
As above, import of sections and page-level-behavior work fully.
Same misbehaviour with various LibreOffice on Linux distros, let alone trying 6.3.2.2 on windows-7-64bit as above!.
Comment 1 enyc 2019-10-20 18:25:24 UTC
Created attachment 155166 [details]
The winword DotX template file, contains sections and special page numbering configuration etc.
Comment 2 enyc 2019-10-20 18:26:13 UTC
Created attachment 155167 [details]
The file as correctly rendered by WinWord-2010, exported as PDF.
Comment 3 enyc 2019-10-20 18:27:27 UTC
Created attachment 155168 [details]
The same file, imported into LO 6.3.2.2 and exported as hybrid PDF file by LO itself.
Comment 4 Mike Kaganski 2019-10-29 08:35:47 UTC
I confirm missing page numbers in footers of odd pages starting with "Page 23 of 47 (Page 1)" when opened in LO Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

The numbers are present on the odd pages in Word 2016.

The missing blanks in PDF are irrelevant here, and are controlled in File->Export As->Export As PDF, on General tab->[x] Export automatically inserted blank pages.
Comment 5 enyc 2019-11-01 20:48:40 UTC
Created attachment 155457 [details]
3-S Template, exported with automatic blank pages, by LO 6.4a1 Win7 32bit.
Comment 6 enyc 2019-11-01 21:02:04 UTC
Thankyou to Mike for particularly helpful comments, especially agree that the issue is not the automatically-inserted blank-pages, which indeed come out correctly when requested explicitly!.

Confirm this issue still exists in LO 6.4a1, as per new attachment.

Infact, PDF page 19 shows the first difference -- "xix" does not come out, a right-hand-side page-number,  yet that on Page 17 and before were okay.

Then, similarly, PDF page 23 [page "1"] and all such beyond with footer "Right Page Footer" do not show any page numbers.  There is clearly some issue with importing the left/right footers correctly within the auto-generated page-styles!.   I observe that manually re-insert the page numbers in all the (messy!) autogenerated styles after import from DOCX, seems to work, they appear to just be "imported as blank"...
Comment 7 Xisco Faulí 2019-11-11 16:28:49 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ff4f2ba3242d303f7f238a7a142440f1f4b1f288

author	Serge Krot <Serge.Krot@cib.de>	2018-12-06 19:11:58 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-01-09 22:30:08 +0100
commit	ff4f2ba3242d303f7f238a7a142440f1f4b1f288 (patch)
tree	e26084095041d94378b9189ea026da22b8e456b6
parent	f22f28e722a8a2efdc42bddba80a3a43025a61fd (diff)
sw: DOCX: recognize TOC title during import

Bisected with: bibisect-linux64-6.3

Adding Cc: to Serge Krot
Comment 8 Buovjaga 2019-11-25 15:27:05 UTC
This was introduced in 6.1.5: https://gerrit.libreoffice.org/#/c/66307/
Comment 9 enyc 2019-11-25 15:42:02 UTC
Further Testing confirms:-

          WORKING   FAILS
=========================================
          5.4.7.2   -
          6.0.7.3   -
6.1.0.1 - 6.1.4.2   6.1.5.1 - 6.1.6.3
6.2.0.1 - 6.2.0.3   6.2.1.1 - 6.2.8.2
                -   6.3.4.1
                -   6.4a1 - 6.4.0.0.beta1

i.e. Seemingly, 6.1.5.1 and 6.2.1.1 introduced the problem which
then remains in 6.3+ and never occured in 6.0- .

It would be good to see this regression corrected for 6.4 release,
and correction backported to routine-update of still-supported versions thereafter.   I can't yet see how this is related to table-of-contents
title exporting bug linked in the related bug....  Puzzle!.
Comment 10 enyc 2020-08-28 04:57:27 UTC
This Might be related to new bug  #136194   .
https://bugs.documentfoundation.org/show_bug.cgi?id=136194
Or, might be unconnected.
Comment 11 Justin L 2021-01-27 09:14:48 UTC
Every page in Chapter one should have a page number in the footer, but only the even pages were getting it. This was probably fixed in LO 6.3.5. According to bibisect-linux-64-7.0, it was fixed by no other than

author	Mike Kaganski on 2019-12-16 17:23:57 +0100
commit	5cdb14345842c07eb1a466897753da910e9488f8 
    tdf#129353, tdf#129402: fix node creation on index import

Although the description of the commit doesn't completely match what I would have expected in the fix for a missing footer page number field, there are hints of dealing with fields, and also not removing paragraphs - which might somehow come into play.