Download it now!
Bug 128274 - Provide a .uno command to paste just copied 'Formats' to a new sheet, supplement to the current PasteSpecial dialog
Summary: Provide a .uno command to paste just copied 'Formats' to a new sheet, supple...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: UNO-Command-New
  Show dependency treegraph
 
Reported: 2019-10-20 11:24 UTC by Ton
Modified: 2019-10-22 11:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ton 2019-10-20 11:24:41 UTC
Description:
In Paste Menu (via customize) you can paste Number, Txt, Formulae, BUT NOT the Format of the cell separately. If it's not a bug then it's a request for the future.

Actual Results:
None

Expected Results:
None


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-10-20 15:45:41 UTC
This paste special feature already is provided:

1). In Calc module

2). From source sheet copy the cells with any formatting desired.

3). On new target sheet, select a cell (with space to hold the selection).

4). With '<Ctrl>+<Shift>+v' (or from context menu Paste Special) open the 'Paste Special' dialog.

5). On the 'Paste Special' dialog, clear all check boxes, and make a check box selection of 'Formats'

6). OK to paste _just_ the cell formatting.


=-testing-=
Windows 10 Home 64-bit en-US with
Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Ton 2019-10-20 18:06:44 UTC
To Mr Stuart Foote:

What you described I already know, of course.
It is a method that takes far too much time if
you only want to copy and paste cell formats 
that is why I hope for an improvement.

Open Tools Customize Go to the Paste Options
You see Paste only Text, Paste only Numbers, Paste only Formula
but NOT Paste only Format.... For that I have to be in that
horrible inefficient Paste Special menu. Why?

I would like to see such an extra Paste format option
for the future. Possible or not? Thank you.
Comment 3 V Stuart Foote 2019-10-20 18:48:09 UTC
Commands to be added as customization require wrapping into a .uno control. That does not exist--the Paste Special -> Formats is an element of the PasteSpecial control.

Not clear there is a valid use case for creating a stand alone .uno command to paste just the 'Formats'

IMHO => WF

But we'll send it through the UX-advise process.

Stuart
Comment 4 Heiko Tietze 2019-10-21 09:21:55 UTC
For what I understand, the request is not to introduce a new UNO command but to enhance the quick access section from the paste special dialog (it has today the options: Values, Values & Formats, and Transpose).

(In reply to V Stuart Foote from comment #3)
> Not clear there is a valid use case for creating a stand alone .uno command
> to paste just the 'Formats'

Me too, also because we have many functions to format cells. So Ton, why don't you work with cell styles or conditional formatting?
Comment 5 Ton 2019-10-21 10:51:52 UTC
Dear Mr Heiko,

I never have used cell styles or conditional formatting because I do not understand them and things I do not understand I don't use: I am always running into trouble...

I copy and paste a lot of external data (snippets) with my clipboard manager into LO. By doing so I loose the cell formatting, I fix this with the Special Paste Menu but then I have to untick two boxes and tick one. When you have to do that 1000 x a year over and over again then you start wondering why I am doing this and if there is no better solution.

I send you a link to my Dropbox account holding a screenshot of the cell context menu of LO. I made modifications (in Dutch) to it like this:

        Paste
              ---> Number
              ---> Text
              ---> Formula

but not Formats because it is not present in the Options Customize menu and I do not understand why. Okay if it is not possible because of technical software problems, then rest my case. But it would already be a great improvement if the user can decide in the Paste Special menu which boxes he wants ticked or unticked and save it.

Okay here is the link:

https://www.dropbox.com/s/9gs6qp5kqohdzpv/Screenshot%202019-10-21%2012.02.33.png?dl=0
  
Thank you and best regards, Ton
Comment 6 Heiko Tietze 2019-10-22 10:24:10 UTC
(In reply to Ton from comment #5)
> I never have used cell styles or conditional formatting because I do not
> understand them

https://help.libreoffice.org/6.3/en-US/text/scalc/01/05120000.html?&DbPAR=CALC&System=UNIX
https://documentation.libreoffice.org/assets/Uploads/Documentation/en/CG4.1/PDF/CG4104-StylesAndTemplates.pdf (in general, the documentation team put a lot of effort into these documentations)

> I copy and paste a lot of external data (snippets) with my clipboard manager
> into LO. By doing so I loose the cell formatting, I fix this with the
> Special Paste Menu but then I have to untick two boxes and tick one. When
> you have to do that 1000 x a year over and over again then you start
> wondering why I am doing this and if there is no better solution.

There is also the autoformat feature https://help.libreoffice.org/6.3/en-US/text/scalc/01/05110000.html?&DbPAR=CALC&System=UNIX

> ... not Formats because it is not present in the Options Customize menu and
> I do not understand why.

The reason is there are plenty of better alternatives. Way better. Please try it first, I bet you save more time than with any UI hack.



Point why I hesitate to agree with your proposal is, if we introduce a new function it should add benefit for many users. For example, "Paste Format" could be mistaken as "Paste Formatted". It also takes space meaning you cannot glace over a few paste options but have to read all - of course not a result of one function but it adds up. Not to speak about maintenance at the code.
Comment 7 Ton 2019-10-22 11:46:04 UTC
Well, as usual I found my own solution: the Paste Special Menu starts with 3 brown buttons at the top and the middle one says Values & Formats. With that option I at least can copy the format of an empty cell to an other empty cell on a sheet without having to handle the tick boxes. I wonder if there are more (hidden) surprises in the Paste Special Menu. Have a nice day.