Download it now!
Bug 128345 - FILESAVE: PPTX: transparency gradient on solid fill is not considered in export
Summary: FILESAVE: PPTX: transparency gradient on solid fill is not considered in export
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Regina Henschel
URL:
Whiteboard: target:7.1.0 target:7.0.1
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2019-10-23 13:12 UTC by Regina Henschel
Modified: 2020-08-11 13:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
SolidWithTransparenceGradient.odp has shape with solid color and transparency gradient (15.00 KB, application/vnd.oasis.opendocument.presentation)
2019-10-23 13:12 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2019-10-23 13:12:04 UTC
Created attachment 155260 [details]
SolidWithTransparenceGradient.odp has shape with solid color and transparency gradient

Open attached file. The shape has a solid yellow fill and a transparency gradient. Save the file to pptx and open it in PowerPoint. The shape has lost transparency.

Suggestion: Export the fill as monochrome gradient and set the transparency of the stops according the transparency gradient.

If PowerPoint uses a monochrome gradient and transparency on the stops, the transparency will be correct, when LibreOffice opens the file.
Comment 1 Xisco Faulí 2019-10-23 13:55:37 UTC
Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: 437dc68285dab0f08a1ded2193d86d64f560cd9b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 2 Xisco Faulí 2019-10-23 13:56:41 UTC
Also reproduced in

Version 4.1.0.0.alpha0+ (Build ID: ff140bb6b8b109f14c270ff059f0b8d71dab5d6)
Comment 3 Xisco Faulí 2019-10-23 14:01:22 UTC
@Regina, is it possible to create a shape with a transparency gradient on solid fill in PowerPoint ?
Comment 4 Regina Henschel 2019-10-23 18:08:03 UTC
(In reply to Xisco Faulí from comment #3)
> @Regina, is it possible to create a shape with a transparency gradient on
> solid fill in PowerPoint ?

No, PowerPoint has no separate transparency gradient, but has transparency only a part of a color gradient. Therefore my suggestion to export it as color gradient, where the start and end value is the same. See also the discussion in bug 108065.
Comment 5 Regina Henschel 2020-07-14 21:04:53 UTC
I will work on it.
Comment 6 Commit Notification 2020-07-18 14:30:19 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d187f22b7ff73954e1da39fb954c64bc315298cb

tdf#128345 pptx export: add transparence gradient in solid fill

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Regina Henschel 2020-07-18 14:36:22 UTC
The patch fixes the error for shapes. A fix for backgrounds in charts is pending. Charts need a separate solution, because their properties do not contain fill gradients directly, but have only the name of a gradient.

I'll continue to work on it.
Comment 8 Commit Notification 2020-08-07 11:44:49 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/855420811e13d620dd1d0f016ac4f7da9535954c

tdf#128345 pptx export: add transparence gradient in solid fill

It will be available in 7.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Regina Henschel 2020-08-07 15:07:57 UTC
The part for charts is in https://gerrit.libreoffice.org/c/core/+/99464

Please review.

The unit tests are now in module sd. I consider to move them to chart2_geometry. But that will be a separate task.
Comment 10 Commit Notification 2020-08-09 10:16:50 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/acfd9e9ca2dfd76536c072e21c65cb3efc6aac80

tdf#128345 PPTX: add transparence gradient for fill in chart

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-08-11 12:13:43 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a6704e6dc53d64bc1442d337f7bfb8deb03f4145

tdf#128345 Move unit tests from sd to chart2 and improve them

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Regina Henschel 2020-08-11 13:03:09 UTC
Data labels and plot-area in pie-charts have principle problems with filling, not only with transparency. Those problems are not handled here. The other cases with transparency should be OK now.