Bug 128346 - Crashed on Mac while searching for updates
Summary: Crashed on Mac while searching for updates
Status: RESOLVED DUPLICATE of bug 127619
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-23 13:28 UTC by Leander.schulten
Modified: 2019-10-24 06:20 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leander.schulten 2019-10-23 13:28:48 UTC
Description:
If I "Check for Updates..." the update window opens and starts searching. After a few seconds, LibreOffice crashs.

Steps to Reproduce:
1. Open LibreOffice
2. Open Help -> check for Updates...
3. Wait

Actual Results:
LibreOffice Crashed

Expected Results:
Should not crash


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
# About Libre Office
Version: 6.3.2.2
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: GL; VCL: osx; 
Locale: de-DE (en_DE.UTF-8); UI-Language: en-US
Calc: threaded

# Crash report from macOS

Process:               soffice [29859]
Path:                  /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:            soffice
Version:               6.3.2002 (6.3.2002)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [29859]
User ID:               501

Date/Time:             2019-10-23 15:10:15.561 +0200
OS Version:            Mac OS X 10.13.6 (17G8037)
Report Version:        12
Anonymous UUID:        5BF10E8D-CE3C-6818-940A-A4A99A5E6479

Sleep/Wake UUID:       46EB3A21-BD01-48A4-B4FE-3F0F5E1C2319

Time Awake Since Boot: 150000 seconds
Time Since Wake:       44000 seconds

System Integrity Protection: enabled

Crashed Thread:        5  UpdateCheckThread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000010
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x10:
--> 
    __TEXT                 0000000101792000-0000000101793000 [    4K] r-x/rwx SM=COW  /Applications/LibreOffice.app/Contents/MacOS/soffice

Application Specific Information:
abort() called

Thread 0:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff59a8e20a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff59a8d724 mach_msg + 60
2   com.apple.CoreFoundation      	0x00007fff31974fc5 __CFRunLoopServiceMachPort + 341
3   com.apple.CoreFoundation      	0x00007fff31974317 __CFRunLoopRun + 1783
4   com.apple.CoreFoundation      	0x00007fff31973987 CFRunLoopRunSpecific + 487
5   com.apple.HIToolbox           	0x00007fff30c53d96 RunCurrentEventLoopInMode + 286
6   com.apple.HIToolbox           	0x00007fff30c53b06 ReceiveNextEventCommon + 613
7   com.apple.HIToolbox           	0x00007fff30c53884 _BlockUntilNextEventMatchingListInModeWithFilter + 64
8   com.apple.AppKit              	0x00007fff2ef03a3b _DPSNextEvent + 2085
9   com.apple.AppKit              	0x00007fff2f699e34 -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 3044
10  libvclplug_osxlo.dylib        	0x0000000108e222d3 AquaSalInstance::DoYield(bool, bool) + 979
11  libvcllo.dylib                	0x000000010461f4e0 Application::Execute() + 336
12  libsofficeapp.dylib           	0x000000010180db69 desktop::Desktop::Main() + 3497
13  libvcllo.dylib                	0x0000000104625e4b ImplSVMain() + 139
14  libvclplug_osxlo.dylib        	0x0000000108e219cb AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 91
15  libvclplug_osxlo.dylib        	0x0000000108e5900d -[VCL_NSApplication sendEvent:] + 77
16  com.apple.AppKit              	0x00007fff2eef887d -[NSApplication run] + 812
17  com.apple.AppKit              	0x00007fff2eec7a3a NSApplicationMain + 804
18  libvclplug_osxlo.dylib        	0x0000000108e23bc9 AquaSalInstance::SVMainHook(int*) + 169
19  libvcllo.dylib                	0x0000000104625e2d ImplSVMain() + 109
20  libsofficeapp.dylib           	0x000000010183b35c soffice_main + 236
21  org.libreoffice.script        	0x0000000101792f60 main + 16
22  libdyld.dylib                 	0x00007fff59947015 start + 1

Thread 1:: PipeIPC
0   libsystem_kernel.dylib        	0x00007fff59a96ece __accept + 10
1   libuno_sal.dylib.3            	0x00000001017c8cf9 osl_acceptPipe + 25
2   libsofficeapp.dylib           	0x0000000101837ea1 desktop::PipeIpcThread::execute() + 65
3   libuno_salhelpergcc3.dylib.3  	0x0000000101f5f59b salhelper::Thread::run() + 27
4   libuno_salhelpergcc3.dylib.3  	0x0000000101f5f70f threadFunc + 15
5   libuno_sal.dylib.3            	0x00000001017d127e osl_thread_start_Impl(void*) + 126
6   libsystem_pthread.dylib       	0x00007fff59c5f661 _pthread_body + 340
7   libsystem_pthread.dylib       	0x00007fff59c5f50d _pthread_start + 377
8   libsystem_pthread.dylib       	0x00007fff59c5ebf9 thread_start + 13

Thread 2:: com.apple.NSEventThread
0   libsystem_kernel.dylib        	0x00007fff59a8e20a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff59a8d724 mach_msg + 60
2   com.apple.CoreFoundation      	0x00007fff31974fc5 __CFRunLoopServiceMachPort + 341
3   com.apple.CoreFoundation      	0x00007fff31974317 __CFRunLoopRun + 1783
4   com.apple.CoreFoundation      	0x00007fff31973987 CFRunLoopRunSpecific + 487
5   com.apple.AppKit              	0x00007fff2f040fc4 _NSEventThread + 184
6   libsystem_pthread.dylib       	0x00007fff59c5f661 _pthread_body + 340
7   libsystem_pthread.dylib       	0x00007fff59c5f50d _pthread_start + 377
8   libsystem_pthread.dylib       	0x00007fff59c5ebf9 thread_start + 13

Thread 3:: OpenGL Watchdog
0   libsystem_kernel.dylib        	0x00007fff59a97a16 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff59c60589 _pthread_cond_wait + 732
2   libuno_sal.dylib.3            	0x00000001017c1e0e osl_waitCondition + 190
3   libvcllo.dylib                	0x00000001046d2ae9 OpenGLWatchdogThread::execute() + 89
4   libuno_salhelpergcc3.dylib.3  	0x0000000101f5f59b salhelper::Thread::run() + 27
5   libuno_salhelpergcc3.dylib.3  	0x0000000101f5f70f threadFunc + 15
6   libuno_sal.dylib.3            	0x00000001017d127e osl_thread_start_Impl(void*) + 126
7   libsystem_pthread.dylib       	0x00007fff59c5f661 _pthread_body + 340
8   libsystem_pthread.dylib       	0x00007fff59c5f50d _pthread_start + 377
9   libsystem_pthread.dylib       	0x00007fff59c5ebf9 thread_start + 13

Thread 4:: OGL Profiler
0   libsystem_kernel.dylib        	0x00007fff59a8e20a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff59a8d724 mach_msg + 60
2   com.apple.opengl              	0x00007fff3be98dcf glcDebugListener + 303
3   libsystem_pthread.dylib       	0x00007fff59c5f661 _pthread_body + 340
4   libsystem_pthread.dylib       	0x00007fff59c5f50d _pthread_start + 377
5   libsystem_pthread.dylib       	0x00007fff59c5ebf9 thread_start + 13

Thread 5 Crashed:: UpdateCheckThread
0   libsystem_kernel.dylib        	0x00007fff59a97b66 __pthread_kill + 10
1   libsystem_pthread.dylib       	0x00007fff59c62080 pthread_kill + 333
2   libsystem_c.dylib             	0x00007fff599f31ae abort + 127
3   libuno_sal.dylib.3            	0x00000001017ce0d1 (anonymous namespace)::signalHandlerFunction(int, __siginfo*, void*) + 753
4   libsystem_platform.dylib      	0x00007fff59c55f5a _sigtramp + 26
5   dyld                          	0x0000000106c86096 ImageLoaderMachOCompressed::resolveTwolevel(ImageLoader::LinkContext const&, char const*, ImageLoader const*, ImageLoader const*, unsigned int, bool, bool, ImageLoader const**) + 86
6   libnssutil3.dylib             	0x00000001815bceb8 SECOID_FindOID_Util + 25
7   libsmime3.dylib               	0x0000000181484ef0 CERT_DecodeCertPackage + 380
8   libnss3.dylib                 	0x000000010534ddcc pkix_pl_HttpCertStore_DecodeCertPackage + 492
9   libnss3.dylib                 	0x000000010534e18d pkix_pl_HttpCertStore_ProcessCertResponse + 685
10  libnss3.dylib                 	0x0000000105347c53 pkix_pl_AIAMgr_GetHTTPCerts + 1923
11  libnss3.dylib                 	0x0000000105348fb1 PKIX_PL_AIAMgr_GetAIACerts + 1073
12  libnss3.dylib                 	0x00000001052ea1e8 pkix_BuildForwardDepthFirstSearch + 2504
13  libnss3.dylib                 	0x00000001052e7759 pkix_Build_InitiateBuildChain + 7049
14  libnss3.dylib                 	0x00000001052e5860 PKIX_BuildChain + 384
15  libnss3.dylib                 	0x000000010521f236 CERT_PKIXVerifyCert + 678
16  libxsec_xmlsec.dylib          	0x000000017ff594d4 SecurityEnvironment_NssImpl::verifyCertificate(com::sun::star::uno::Reference<com::sun::star::security::XCertificate> const&, com::sun::star::uno::Sequence<com::sun::star::uno::Reference<com::sun::star::security::XCertificate> > const&) + 1028
17  libucpdav1.dylib              	0x0000000180bb8675 webdav_ucp::NeonSession::CertificationNotify(ne_ssl_certificate_s const*) + 981
18  libneon.dylib                 	0x000000018107de7a ne__negotiate_ssl + 666
19  libneon.dylib                 	0x00000001810759f6 send_request + 1174
20  libneon.dylib                 	0x0000000181074ec4 ne_begin_request + 228
21  libneon.dylib                 	0x0000000181076218 ne_request_dispatch + 40
22  libucpdav1.dylib              	0x0000000180bbb670 webdav_ucp::NeonSession::OPTIONS(rtl::OUString const&, webdav_ucp::DAVOptions&, webdav_ucp::DAVRequestEnvironment const&) + 256
23  libucpdav1.dylib              	0x0000000180ba97ba webdav_ucp::DAVResourceAccess::OPTIONS(webdav_ucp::DAVOptions&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 410
24  libucpdav1.dylib              	0x0000000180be4353 webdav_ucp::Content::getResourceOptions(com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&, webdav_ucp::DAVOptions&, std::__1::unique_ptr<webdav_ucp::DAVResourceAccess, std::__1::default_delete<webdav_ucp::DAVResourceAccess> > const&, bool*) + 179
25  libucpdav1.dylib              	0x0000000180bda9a4 webdav_ucp::Content::open(com::sun::star::ucb::OpenCommandArgument3 const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 1844
26  libucpdav1.dylib              	0x0000000180bd149c webdav_ucp::Content::execute(com::sun::star::ucb::Command const&, int, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 2828
27  libucpdav1.dylib              	0x0000000180be05d2 non-virtual thunk to webdav_ucp::Content::execute(com::sun::star::ucb::Command const&, int, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 18
28  libupdatefeedlo.dylib         	0x000000017fcd4460 (anonymous namespace)::UpdateInformationProvider::load(rtl::OUString const&) + 1088
29  libupdatefeedlo.dylib         	0x000000017fccfd7e (anonymous namespace)::UpdateInformationProvider::getUpdateInformationEnumeration(com::sun::star::uno::Sequence<rtl::OUString> const&, rtl::OUString const&) + 206
30  libupdatefeedlo.dylib         	0x000000017fcd1102 non-virtual thunk to (anonymous namespace)::UpdateInformationProvider::getUpdateInformationEnumeration(com::sun::star::uno::Sequence<rtl::OUString> const&, rtl::OUString const&) + 18
31  libupdchklo.dylib             	0x000000010c5bc688 checkForUpdates(UpdateInfo&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&, com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler> const&, com::sun::star::uno::Reference<com::sun::star::deployment::XUpdateInformationProvider> const&, rtl::OUString const&, rtl::OUString const&, com::sun::star::uno::Sequence<rtl::OUString> const&, rtl::OUString const&, rtl::OUString const&) + 248
32  libupdchklo.dylib             	0x000000010c5bc409 checkForUpdates(UpdateInfo&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&, com::sun::star::uno::Reference<com::sun::star::task::XInteractionHandler> const&, com::sun::star::uno::Reference<com::sun::star::deployment::XUpdateInformationProvider> const&) + 697
33  libupdchklo.dylib             	0x000000010c59f6d6 (anonymous namespace)::UpdateCheckThread::runCheck(bool&) + 278
34  libupdchklo.dylib             	0x000000010c59f29c (anonymous namespace)::UpdateCheckThread::run() + 412
35  libupdchklo.dylib             	0x000000010c59d49f threadFunc + 15
36  libuno_sal.dylib.3            	0x00000001017d127e osl_thread_start_Impl(void*) + 126
37  libsystem_pthread.dylib       	0x00007fff59c5f661 _pthread_body + 340
38  libsystem_pthread.dylib       	0x00007fff59c5f50d _pthread_start + 377
39  libsystem_pthread.dylib       	0x00007fff59c5ebf9 thread_start + 13

Thread 6:: Dispatch queue: NSCGSDisableUpdates
0   libsystem_kernel.dylib        	0x00007fff59a8e20a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff59a8d724 mach_msg + 60
2   com.apple.SkyLight            	0x00007fff536ec1b9 CGSUpdateManager::enable_updates_common() + 565
3   com.apple.SkyLight            	0x00007fff5369030c CGSUpdateManager::enable_update(unsigned long long) + 320
4   libdispatch.dylib             	0x00007fff599155fa _dispatch_call_block_and_release + 12
5   libdispatch.dylib             	0x00007fff5990ddb8 _dispatch_client_callout + 8
6   libdispatch.dylib             	0x00007fff59922217 _dispatch_queue_serial_drain + 635
7   libdispatch.dylib             	0x00007fff59915166 _dispatch_queue_invoke + 373
8   libdispatch.dylib             	0x00007fff59922f0d _dispatch_root_queue_drain_deferred_wlh + 332
9   libdispatch.dylib             	0x00007fff59926d21 _dispatch_workloop_worker_thread + 880
10  libsystem_pthread.dylib       	0x00007fff59c5efd2 _pthread_wqthread + 980
11  libsystem_pthread.dylib       	0x00007fff59c5ebe9 start_wqthread + 13

Thread 7:
0   libsystem_pthread.dylib       	0x00007fff59c5ebdc start_wqthread + 0
1   ???                           	0x7265666572504643 0 + 8243107278867154499

Thread 8:
0   libsystem_pthread.dylib       	0x00007fff59c5ebdc start_wqthread + 0
1   ???                           	0x696c706200000036 0 + 7596570237676290102

Thread 9:: GrammarCheckingIterator
0   libsystem_kernel.dylib        	0x00007fff59a97a16 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff59c60589 _pthread_cond_wait + 732
2   libuno_sal.dylib.3            	0x00000001017c1e3b osl_waitCondition + 235
3   liblnglo.dylib                	0x000000010645d89e GrammarCheckingIterator::DequeueAndCheck() + 94
4   libuno_sal.dylib.3            	0x00000001017d127e osl_thread_start_Impl(void*) + 126
5   libsystem_pthread.dylib       	0x00007fff59c5f661 _pthread_body + 340
6   libsystem_pthread.dylib       	0x00007fff59c5f50d _pthread_start + 377
7   libsystem_pthread.dylib       	0x00007fff59c5ebf9 thread_start + 13

Thread 5 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x000070000f2c0000  rcx: 0x000070000f2bdf38  rdx: 0x0000000000000000
  rdi: 0x0000000000014107  rsi: 0x0000000000000006  rbp: 0x000070000f2bdf70  rsp: 0x000070000f2bdf38
   r8: 0x00007fff9203f9e8   r9: 0xffffffff00000000  r10: 0x0000000000000000  r11: 0x0000000000000206
  r12: 0x0000000000014107  r13: 0x00007f90b32e7f70  r14: 0x0000000000000006  r15: 0x000000000000002d
  rip: 0x00007fff59a97b66  rfl: 0x0000000000000206  cr2: 0x00007fff9203d168
  
Logical CPU:     0
Error Code:      0x02000148
Trap Number:     133


Binary Images:
       # removed because comment was too long...

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 213
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 21478632
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=541.3M resident=0K(0%) swapped_out_or_unallocated=541.3M(100%)
Writable regions: Total=206.8M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=206.8M(100%)
 
                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Accelerate framework               256K        2 
Activity Tracing                   256K        2 
CG backing stores                 4508K        5 
CG image                            24K        6 
CG raster data                     552K        9 
CoreAnimation                       44K        8 
CoreGraphics                         8K        2 
CoreImage                            8K        3 
CoreUI image data                 1240K       16 
CoreUI image file                  180K        4 
Dispatch continuations            4096K        2 
Foundation                          28K        3 
Image IO                             4K        2 
Kernel Alloc Once                    8K        2 
MALLOC                           174.5M      134 
MALLOC guard page                   48K       13 
MALLOC_LARGE (reserved)           4136K        3         reserved VM address space (unallocated)
Memory Tag 242                      12K        2 
OpenGL GLSL                        256K        4 
SQLite page cache                  704K        6 
STACK GUARD                       56.0M       11 
Stack                             12.6M       13 
VM_ALLOCATE                       4220K       32 
__DATA                            51.9M      420 
__FONT_DATA                          4K        2 
__GLSLBUILTINS                    2588K        2 
__LINKEDIT                       240.7M      139 
__TEXT                           300.7M      394 
__UNICODE                          560K        2 
mapped file                        1.7G      483 
shared memory                     2980K       17 
===========                     =======  ======= 
TOTAL                              2.6G     1712 
TOTAL, minus reserved VM space     2.6G     1712 

Model: MacBookPro7,1, BootROM 68.0.0.0.0, 2 processors, Intel Core 2 Duo, 2,4 GHz, 8 GB, SMC 1.62f7
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x029E, 0x434D5341344758334D314131303636433720
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x029E, 0x434D5341344758334D314131303636433720
Comment 1 Alex Thurgood 2019-10-24 06:20:12 UTC

*** This bug has been marked as a duplicate of bug 127619 ***