Bug 128358 - Pictures (logo) in the headline of a document are not printed anymore
Summary: Pictures (logo) in the headline of a document are not printed anymore
Status: RESOLVED DUPLICATE of bug 129085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-10-23 19:56 UTC by C.R.
Modified: 2020-09-23 11:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
template (27.92 KB, application/vnd.oasis.opendocument.text)
2019-10-25 13:17 UTC, C.R.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description C.R. 2019-10-23 19:56:16 UTC
Description:
Logos (pictures) which are part of the headline of a document are not printed anymore. 

The last version this error did not occur which was tested here is 6.1.5.2. 

I tried the versions 6.2.7 and 6.2.8. (stable release) each did not print the pictures anymore. The position where the picture is located is empty on the printed page. The pictures are files with 600dpi.

After reinstalling Version 6.1.5.2. the error was fixed, the printed pages were complete again. 

Steps to Reproduce:
1. Open File
2. chose print file
3. Logo (picture) in the headline is missing.

Actual Results:
Printed page is incomplete headline with logo is missing

Expected Results:
Printed page should contain headline with logo 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 1 Oliver Brinzing 2019-10-24 17:32:41 UTC
Thank you for reporting the bug.

Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 C.R. 2019-10-25 13:17:13 UTC
Created attachment 155308 [details]
template

Further Information to the error. 

An Openoffice "export to PDF" contains the logos. As soon as you choose to "print" the file to a real or even a virtiual printer the logo disappears.
Comment 3 Oliver Brinzing 2019-10-26 09:32:53 UTC
reproducible with:

Version: 6.1.6.3 (x64)
Build-ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: 

Version: 6.4.0.0.alpha1+ (x64)
Build ID: 706afd3e765e98489a2b43934a259626f9f0be01
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

but *not* reproducible with:

Version: 6.0.7.3 (x64)
Build-ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc:
Comment 4 Oliver Brinzing 2019-10-26 12:42:23 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/c2ae30b19d8145271f1189c9757d59d43de391c7

commit c2ae30b19d8145271f1189c9757d59d43de391c7	[log]
author	Armin Le Grand <Armin.Le.Grand@me.com>	
Tue Apr 02 17:59:40 2019 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>
Wed Apr 03 12:32:38 2019 +0200
tree eaed7ddd4b2327e71deccca512918d9d88765927
parent 1dc8088162a66a99217dae3258711cbfa8f9bc28 [diff]

tdf#124272 use ClipRegion's geometry if not a rectangle

By error the ClipRegion's geometry was replaced by it's
BoundRect expanded to PixelBounds. If the ClipRegion
is not a rectangle, this will create wrong results. To
do both - extend to PixelBounds and have the original
geometry included - use the PolyPolygon topology as
needed (see comment in code for details)


/cygdrive/d/sources/bibisect/bibisect-win32-6.1
$ git bisect bad 9fece659449bb32e68180870a6816c4baeca2c26 is the first bad commit
commit 9fece659449bb32e68180870a6816c4baeca2c26
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Apr 3 09:17:35 2019 -0700
    source c2ae30b19d8145271f1189c9757d59d43de391c7

    source c2ae30b19d8145271f1189c9757d59d43de391c7

:040000 040000 84f14d39f9d1c271805229ede09f3f5fe778aedb b057d201a9e44958a28fc5cf09ffc2a4285a67cf M      instdir

/cygdrive/d/sources/bibisect/bibisect-win32-6.1
$ git bisect log
# bad: [75d131082ce51ed5a898d97bdc2b7a9fe5ddb340] source 5b3765f4d881e7ddefd0c4aad6886a46f000b4fc
# good: [29d08f54c2f71ffee4fe12dbb24c5f5cbedecfd2] source 6eeac3539ea4cac32d126c5e24141f262eb5a4d9
git bisect start 'master' 'oldest'
# good: [6227e15df9be101688e37cd891817cd858b49e03] source b8b7f8a8f8d97088181d287bb75e74facece16c6
git bisect good 6227e15df9be101688e37cd891817cd858b49e03
# good: [50b236fe0d359b9d5cc9998d2e72009a90a11d08] source b6025e6cffe2024fefebd161ea739188b4b4fdaf
git bisect good 50b236fe0d359b9d5cc9998d2e72009a90a11d08
# good: [d59609a1bfbbb4f924492755719b7d340a51de1b] source eeaf4b0b7ad21da879554bdd93c9a9b97b8268d6
git bisect good d59609a1bfbbb4f924492755719b7d340a51de1b
# good: [75029ade8fd0bbe5abc530394b85b346b499bc55] source ec79d0127f90d65d722e46688b6cfcf2f5e59794
git bisect good 75029ade8fd0bbe5abc530394b85b346b499bc55
# good: [ab0db3bf58bf2ed341d05f62c0beefc85c134af3] source 6ed498a71482109fea731bb84f288f978bea12dc
git bisect good ab0db3bf58bf2ed341d05f62c0beefc85c134af3
# good: [57e9a0f44d3c2897d9eeb10ef46648de5022324f] source 71fad56863301f47f19fdd47ab93099ad098474e
git bisect good 57e9a0f44d3c2897d9eeb10ef46648de5022324f
# good: [d9690e045610c28302b61e40881752beab19daf1] source 439407a36e4085c17c65c620a1bb2ca95f4564b0
git bisect good d9690e045610c28302b61e40881752beab19daf1
# good: [480406d3bbda42e216ea9f352f955839fe1afe45] source 0c70e9ab4713a50fec558d6c4e4dfb2517039fc8
git bisect good 480406d3bbda42e216ea9f352f955839fe1afe45
# bad: [c56412b9a81d276e42f739cc70727b0f6e992442] source f15146021b722dda0cf10cb08de6e0a3c525168a
git bisect bad c56412b9a81d276e42f739cc70727b0f6e992442
# good: [ef9cc0fb37a2e406a4b88c64d44f2e9517f15a2e] source bc5d04dfe4e53880bab21eff5a2071b368d918c1
git bisect good ef9cc0fb37a2e406a4b88c64d44f2e9517f15a2e
# good: [0782b432484cb2e1ce1ce782ced58fb1641d14e9] source 1dc8088162a66a99217dae3258711cbfa8f9bc28
git bisect good 0782b432484cb2e1ce1ce782ced58fb1641d14e9
# bad: [2f290c89eb09fb3d6cf5851a53318b48e1473b9d] source 39de7d73fdab86a1531f19076ab1d07fcff97b55
git bisect bad 2f290c89eb09fb3d6cf5851a53318b48e1473b9d
# bad: [9fece659449bb32e68180870a6816c4baeca2c26] source c2ae30b19d8145271f1189c9757d59d43de391c7
git bisect bad 9fece659449bb32e68180870a6816c4baeca2c26
# first bad commit: [9fece659449bb32e68180870a6816c4baeca2c26] source c2ae30b19d8145271f1189c9757d59d43de391c7
Comment 5 Timur 2020-09-23 11:17:06 UTC
let keep together.

*** This bug has been marked as a duplicate of bug 129085 ***