Bug 128410 - Dialog "Conditional formatting for" is too small, shows only title
Summary: Dialog "Conditional formatting for" is too small, shows only title
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Conditional-Formatting-Editing
  Show dependency treegraph
 
Reported: 2019-10-27 07:43 UTC by Oliver Brinzing
Modified: 2019-10-29 08:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (28.10 KB, image/png)
2019-10-27 07:43 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Brinzing 2019-10-27 07:43:04 UTC
Created attachment 155334 [details]
screenshot

steps to reproduce:

- Menu Format/Conditional/Manage...
- [Add]

Dialog "Conditional formatting for" is to small, shows only title - it's possible to resize.


Version: 6.4.0.0.alpha1+ (x64)
Build ID: 706afd3e765e98489a2b43934a259626f9f0be01
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 1 Xavier Van Wijmeersch 2019-10-27 10:26:21 UTC
cannot reproduce with

Version: 6.4.0.0.alpha1+
Build ID: b7735d9c705bdec53ddb0077b93ae70ce4c2df48
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded

maybe only windows???
Comment 2 Roman Kuznetsov 2019-10-27 11:34:58 UTC
hm.. I don't see even dialog title in

Version: 6.4.0.0.alpha1+
Build ID: 706afd3e765e98489a2b43934a259626f9f0be01
CPU threads: 4; OS: Mac OS X 10.15; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

don't repro in

Version: 6.3.2.1
Build ID: db810050ff08fd4774137f693d5a01d22f324dfd
CPU threads: 4; OS: Mac OS X 10.15; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

so it's a regression
Comment 3 m.a.riosv 2019-10-27 14:42:36 UTC
Repro with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 758516295e5f69393bd78bb4af6e7214d48ece0b
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 4 Roman Kuznetsov 2019-10-27 20:56:12 UTC
I bisected it

$ git bisect bad
b1b98ed970c7e244eaa523dc43c49a59f5352b68 is the first bad commit
commit b1b98ed970c7e244eaa523dc43c49a59f5352b68
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon Sep 30 12:07:36 2019 -0700

    source sha:65977a839d1de4ed801ae6803371bf5ba7ee799a

https://gerrit.libreoffice.org/#/c/79873/

Added CC: to Caloan McNamara
Comment 5 Caolán McNamara 2019-10-28 19:27:00 UTC
wrong field with 0s in it
Comment 6 Commit Notification 2019-10-29 08:20:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8aa327ab3e55b2978da31764afcfbdc545ffc0b0

Resolves: tdf#128410 wrong size request for dialog

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.