Bug 128431 - Synchronize padding in header borders it is not working
Summary: Synchronize padding in header borders it is not working
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.4 target:6.5.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Borders-Tab
  Show dependency treegraph
 
Reported: 2019-10-28 12:43 UTC by BogdanB
Modified: 2019-11-21 05:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
video of the bug (303.53 KB, video/mp4)
2019-10-28 12:44 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BogdanB 2019-10-28 12:43:49 UTC
Description:
See the video.
Insert a header. Change the border for a header. And inspite of Syncronize being ACTIVE the fields don't syncronize.

Steps to Reproduce:
1. Insert Header and format it
2. Change the padding for a header when Synconize is active
3. Fields are not syncronized

Actual Results:
Fields not syncronized

Expected Results:
Fields should be syncronized


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.2.2
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 BogdanB 2019-10-28 12:44:07 UTC
Created attachment 155367 [details]
video of the bug
Comment 2 Durgapriyanka 2019-10-28 15:55:45 UTC
Thank you for reporting the bug. I cannot reproduce the bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Buovjaga 2019-10-28 18:17:50 UTC
Repro on Win and Linux

Version: 6.4.0.0.alpha1+ (x64)
Build ID: 7c6226bee72805db7f0e567ca9f06c786a7d0da2
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.4.0.0.alpha1+
Build ID: e70ccc06094bec12d1947328b98ea040b46d08fc
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 28 October 2019

(In reply to Durgapriyanka from comment #2)
> Thank you for reporting the bug. I cannot reproduce the bug in
> 
> Version: 6.3.0.0.alpha0+
> Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
> CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
> TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
> Locale: en-US (en_US); UI-Language: en-US
> Calc: threaded

Please install a fresh version. The version from January 2019 is quite old and it is not good to use it for testing. You can use a build produced by this box: https://dev-builds.libreoffice.org/daily/master/Win-x86_64@tb77-TDF/
Comment 4 BogdanB 2019-10-28 20:11:03 UTC
I bibisected this bug:
this is what I found:

bogdan@bogdan-H110M-S2H:~/Libre Office bibisect/bibisect-linux-64-6.3$ git bisect bad && instdir/program/soffice
b2fe7fe3d00290afceed2e8e49493792dce7b0a5 is the first bad commit
commit b2fe7fe3d00290afceed2e8e49493792dce7b0a5
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Mar 1 00:14:50 2019 +0100

    source sha:55042cb54fea5f7ad777c03af9bf8197127b6736
    
    source sha:55042cb54fea5f7ad777c03af9bf8197127b6736

:040000 040000 949777573484af027ed76de518c022bde488835a de8c351d3352ebc589863392af8e2fe591ecfb01 M	instdir
Comment 5 Buovjaga 2019-10-29 08:50:53 UTC
(In reply to BogdanB from comment #4)
> I bibisected this bug:
> this is what I found:
> 
> bogdan@bogdan-H110M-S2H:~/Libre Office bibisect/bibisect-linux-64-6.3$ git
> bisect bad && instdir/program/soffice
> b2fe7fe3d00290afceed2e8e49493792dce7b0a5 is the first bad commit
> commit b2fe7fe3d00290afceed2e8e49493792dce7b0a5
> Author: Jenkins Build User <tdf@pollux.tdf>
> Date:   Fri Mar 1 00:14:50 2019 +0100
> 
>     source sha:55042cb54fea5f7ad777c03af9bf8197127b6736
>     
>     source sha:55042cb54fea5f7ad777c03af9bf8197127b6736
> 
> :040000 040000 949777573484af027ed76de518c022bde488835a
> de8c351d3352ebc589863392af8e2fe591ecfb01 M	instdir

Yep, looks legit:
"tdf#116382 Replace old dialog in header and footer drop-down menu

Remove the Background tabpage in "Border/Background" dialog accessed
from Border and Background menu item in Header/Footer drop-down list
and replace it with the tabpages "Area" and "Transparency" of the dialog
accessed from Page Style > Header > "More.." button.
 The old dialog does not have the tabpages "Area" and "Transparency". 
In simpler words, the patch is to match both the dialogs
when accessed in two different ways."

It seems Aditya is not contributing anymore. Jim: maybe you have an idea on how to make the padding synch again.
Comment 6 Jim Raykowski 2019-10-31 04:51:54 UTC
My fault, I missed that when reviewing the patch. The same cause of the padding sync not working is the cause of the line arrangement and line items not being filled when the Border / Background dialog is opened from the frame menu.

Here is a link to the patch:
https://gerrit.libreoffice.org/#/c/81815/
Comment 7 Buovjaga 2019-10-31 08:25:21 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2019-10-31 08:26:27 UTC
(In reply to Buovjaga from comment #7)
> Tested with the patch and it works as advertised! Thanks.

Oops, made that last comment in ninja edit mode, so no email was sent.
Comment 9 Commit Notification 2019-10-31 20:38:21 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cec27978b869309dcaf84faf000106fefe0ab166

tdf#128431 Box info item is needed by the Border Background dialog

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Jim Raykowski 2019-10-31 20:42:25 UTC
@Buovjaga - Thanks for testing. The original patch was backported to 6.1 and 6.2 so maybe this patch should be backported to those versions as well as 6.3.
Comment 11 Buovjaga 2019-10-31 21:22:33 UTC
(In reply to Jim Raykowski from comment #10)
> @Buovjaga - Thanks for testing. The original patch was backported to 6.1 and
> 6.2 so maybe this patch should be backported to those versions as well as
> 6.3.

LibreOffice release train has the speed of a bullet - 6.2.8 was the last release of that branch: https://wiki.documentfoundation.org/ReleasePlan/6.2#6.2.8_release
Comment 12 Xisco Faulí 2019-11-04 09:58:17 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: fa7f07d23de31e5f1660a643d83ca8a2e565f69c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Jim, thanks for fixing this issue. Should it be closed as RESOLVED FIXED?
Backported to 6-3 in https://gerrit.libreoffice.org/#/c/81991/
Comment 13 Commit Notification 2019-11-04 12:53:07 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/f0da825749968d22a05c7257b812378c6b2f0ecf

tdf#128431 Box info item is needed by the Border Background dialog

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-11-21 05:39:40 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6b1fb5eaaa170b578797819a83dccf7c89397829

uitest for bug tdf#128431

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.