Bug 128489 - Writer crashes when bibliography database selected, when Base isn't installed
Summary: Writer crashes when bibliography database selected, when Base isn't installed
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2019-10-31 06:37 UTC by stragu
Modified: 2019-11-29 10:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stragu 2019-10-31 06:37:50 UTC
Description:
When libreoffice-base is not installed, opening the "Bibliography Database" tool crashes Writer.

This seems to be a regression, as the same problem has been fixed before: https://bugs.documentfoundation.org/show_bug.cgi?id=33266

Steps to Reproduce:
1. Install libreoffice without Base
2. Open Writer
3. Tools > Bibliography Database

Actual Results:
The program crashes.

Expected Results:
The Bibliography Database window opens.


Reproducible: Always


User Profile Reset: No



Additional Info:
System details:

Version: 6.3.2.2
Build ID: 1:6.3.2-0ubuntu0.18.04.1~lo1
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded

On Ubuntu 18.04.2 64-bit.
Comment 1 Xisco Faulí 2019-11-08 11:54:20 UTC
Hello stragu,
Out of curiosity, How can you install LibreOffice without Base?
I've just tried on windows and the installed doesn't offer that option
Comment 2 stragu 2019-11-09 13:25:36 UTC
I guess that happened to me on an Ubuntu-derivative because I used, after adding a PPA:

   sudo apt install libreoffice

instead of:

   sudo apt install libreoffice libreoffice-base

Not sure about Windows. The "reduced user installation (without Base)" option doesn't exist anymore?
Comment 3 Stanislaus J. Pinasthika 2019-11-29 10:56:11 UTC
Thank you for reporting in.
You may install LibreOffice Base so the problem will be fixed.
https://ask.libreoffice.org/en/question/9231/no-base-in-ubuntu/
Change to Resolved