Bug 128517 - Cyclic or iterative calculation is erroneously assumed in calc 6.3.2.2
Summary: Cyclic or iterative calculation is erroneously assumed in calc 6.3.2.2
Status: RESOLVED DUPLICATE of bug 124270
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calculate Calc-Threaded
  Show dependency treegraph
 
Reported: 2019-10-31 18:16 UTC by Alain Touret
Modified: 2019-12-28 16:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
a calc file that exhibits the buggy behavior (225.71 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-10-31 18:19 UTC, Alain Touret
Details
screenshot LO 633 (84.19 KB, image/png)
2019-10-31 18:31 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alain Touret 2019-10-31 18:16:04 UTC
Description:
The enclosed sheet used to work in calc version 6.2.8 but generates many calc 522 errors in version 6.3.2.2. 

Steps to Reproduce:
1.open the enclosed spreadsheet in calc 6.3.2.2
2.go to sheet "Synthese", column "Rattrapage TVA a psoteriori" (column L)
3.it shows an error 522, the error propagates throughout the spreadsheets
4.open the enclosed spreadsheet in calc 6.2.8
5.go to sheet "Synthese", column "Rattrapage TVA a psoteriori" (column L)
6.it shows the result of a processing (0), there may be some propagation problems (data processing does not get always automatically actualized on other sheets) but most often, the results are ok


Actual Results:
In libreoffice 6.0.7.3 this column (L) in "Synthese", as some parts of the spreadsheet are not calculated : #N/A results

In libreoffice 6.2.8 the spreadsheet is usually well calculated, this column results in numbers, not error. Please note that the refresh and propagation of the data modification (between sheets) is not well done and sometimes needs some manual modification on the destination sheet to be refreshed. 

In libreoffice 6.3.2.2 most parts of the spreadsheet are not calculated : error 522 results (even with iteration validated in parameters)


Expected Results:
The L column shall be always 0 due to the parameters adopted. 
This spreadsheet has worked on libreoffice 6.2.8 (with refreshing and propagation problems). This column shall result in numbers, not error. The propagation of calculations shall be done across all the right side sheets (with names not only made of uppercase characters), including "Fiscalité". 


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Alain Touret 2019-10-31 18:19:58 UTC
Created attachment 155431 [details]
a calc file that exhibits the buggy behavior

For bug demonstration only.
Comment 2 Oliver Brinzing 2019-10-31 18:31:32 UTC
Created attachment 155432 [details]
screenshot LO 633

i can not confirm Err:522, column L shows #N/A for me.

if enabled, can you please try again after disabling:

- Menu Tools/Options.../LibreOffice Calc/Calculate
  -> [ ] Enable multi-threaded calculation
Comment 3 Oliver Brinzing 2019-10-31 20:38:54 UTC
it's reproducible with:

Version: 6.4.0.0.alpha1+ (x64)
Build ID: 885ae558d34dd76955c727b90eb9ae52ce85df7f
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

but *not* reproducible with disabled 
[ ] Enable multi-threaded calculation
Comment 4 m.a.riosv 2019-10-31 23:14:42 UTC
Looks like a duplicate, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 124270 ***
Comment 5 b. 2019-12-28 16:54:15 UTC
i don't think duplicate, and never ever of that one (#124270), but user error ... changed behaviour ... 

the initial fail is cells U5:U8 on sheet Synthese not finding 2016 in '_fiscalita_an' or similar, 

in older versions - i tested with 5.0.0.1 - that's somehow 'ignored' by dependent cells, in 6.4.0.1 and 6.5.0.0.a0 it's handed over to them / inherited by them, and let's them display as #NA! as well, propagating all over the sheet, 

pls. retest and close with app. status

reg. 

b.