Bug 128521 - illegal char in a bookmark name
Summary: illegal char in a bookmark name
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Bookmarks
  Show dependency treegraph
 
Reported: 2019-10-31 21:59 UTC by TorrAB
Modified: 2019-11-19 15:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2019-10-31 21:59:33 UTC
Entering an illegal char (such as \) in a bookmark name immediately causes an error msg:
'The following characters are not valid…'
    **The msg should read 'The following character is…' since one cannot even enter another character!
    **The msg occurs too soon. Maybe I was trying to enter '\j' which a keyboard manager would have replaced with 'John', which is legal.
    Conclusion: LO should wait to check the bookmark name until the user enters it.
Comment 1 Dieter 2019-11-03 17:12:00 UTC
Form me it looks like an enhancement. I don't see the need to implemen it, but let's ask Design-Team.
Comment 2 Heiko Tietze 2019-11-04 08:57:02 UTC
You can paste text like \o/ into the line and get "characters removed: /\". We could name it "The following character(s) is/are not valid." but this has negative bearing on readability and is a common usability issue.

The best solution is to allow wrong characters but warn immediately without interrupting the workflow. Typically done by a red text next to the input. And the confirmation action (okay button, double-click, context menu) is disabled.

Shall we keep the ticket open or resolve as WF?
Comment 3 Heiko Tietze 2019-11-07 11:06:54 UTC
(In reply to Heiko Tietze from comment #2)
> ... we keep the ticket open...

and remove the confirmation box in favor of a non-disruptive warning text.
Comment 4 Heiko Tietze 2019-11-07 15:22:31 UTC
https://gerrit.libreoffice.org/#/c/82231/
Comment 5 Commit Notification 2019-11-11 08:49:00 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/56b124c36cff09257d8373aaa6661a88cfb1926d

Resolves tdf#128521 - illegal char in a bookmark name

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Dieter 2019-11-19 15:52:39 UTC
Verified with

Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Heiko, thanks for fixing it!