Bug 128625 - UI Multiple radio buttons selected in Error Bars dialog (non-gtk3)
Summary: UI Multiple radio buttons selected in Error Bars dialog (non-gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-06 10:30 UTC by NISZ LibreOffice Team
Modified: 2019-11-12 15:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Writer (13.67 KB, application/binary)
2019-11-06 10:31 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Writer (35.45 KB, image/png)
2019-11-06 10:31 UTC, NISZ LibreOffice Team
Details
The dialog after my proposed patch (40.62 KB, image/png)
2019-11-07 18:23 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-11-06 10:30:54 UTC
Description:
In the Error Bars dialog when opened for a data series three radio buttons are selected under “Error Category”.
This problem does not happen with the GTK3 backend, but happens on others like Windows and QT5


Steps to Reproduce:
1.	Insert a simple chart in Writer
2.	Select one data series by clicking on the line
3.	Choose Insert – X / Y Error Bars


Actual Results:
The X/Y Error Bars for Data Series dialog shows up with three options selected under Error Category.

Expected Results:
Only one option selected.


Reproducible: Always


User Profile Reset: No



Additional Info:
Additional Information: 

Bibisected using bibisect-win32-6.3 to: 
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=d4d2cd593231f97cff938d7d6b30527e310c4244 
author	Justin Luth <justin.luth@collabora.com>	2019-06-15 22:15:32 +0300
committer	Adolfo Jayme Barrientos <fitojb@ubuntu.com>	2019-06-28 09:51:22 +0200
tdf#125609 c10 vcl/button: enforce only one radio selected on init
Comment 1 NISZ LibreOffice Team 2019-11-06 10:31:21 UTC
Created attachment 155570 [details]
Example file from Writer
Comment 2 NISZ LibreOffice Team 2019-11-06 10:31:54 UTC
Created attachment 155571 [details]
Screenshot of the problem in Writer
Comment 3 NISZ LibreOffice Team 2019-11-06 10:33:35 UTC
Adding CC to: Justin Luth
Comment 4 Xisco Faulí 2019-11-06 15:36:21 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha1+
Build ID: ee909ca2c02f949605f68720c3f1eef658502749
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-11-06 15:42:53 UTC
Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: ee909ca2c02f949605f68720c3f1eef658502749
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Justin L 2019-11-06 16:21:39 UTC
This also affects 6.3.0.1
Comment 7 Gabor Kelemen 2019-11-07 07:02:45 UTC
(In reply to Xisco Faulí from comment #4)
> I can't reproduce it in
> 
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Me neither, this is why the title says "non-gtk3" ;)
Comment 8 Xisco Faulí 2019-11-07 09:28:03 UTC
(In reply to Gabor Kelemen from comment #7)
> (In reply to Xisco Faulí from comment #4)
> > I can't reproduce it in
> > 
> > CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> 
> Me neither, this is why the title says "non-gtk3" ;)

indeed, I read it afterwards...
Comment 9 Gabor Kelemen 2019-11-07 18:23:25 UTC
Created attachment 155616 [details]
The dialog after my proposed patch

Proposed patch:

https://gerrit.libreoffice.org/82247

This also fixes the vertical alignment of labels in the Error Indicator group
Comment 10 Caolán McNamara 2019-11-07 21:05:00 UTC
I imagine the problem is the multiple "active" properties set on all the radiobuttons ? If its just set on the first on each column and unset on the others then does all go well ?
Comment 11 Commit Notification 2019-11-07 21:34:18 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3fe387010f97881cc8c5395348b73e080a9a3c4d

tdf#128625 Fix radio button alignments in Error Bars dialog

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-11-08 07:56:24 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/6c27143563234245e5c10dd65d85470ddbfb157f

tdf#128625 Fix radio button alignments in Error Bars dialog

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-11-08 08:53:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b94dd252730512f14d6939a250152b3e4c9e7583

tdf#128625 set only one active radiobutton per group

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-11-08 12:20:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/fc4a7b464a7fe8a2f4fa043db77efc9c48809756

tdf#128625 set only one active radiobutton per group

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2019-11-11 13:02:25 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: fea5c10e222b10d83e0081dc1d1b2e678689d250
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Gabor Kelemen, thanks for fixing this issue!