Download it now!
Bug 128675 - Error export formula in MS office 2007~2019 format
Summary: Error export formula in MS office 2007~2019 format
Status: RESOLVED DUPLICATE of bug 119170
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2019-11-08 16:00 UTC by Army_bloodcore
Modified: 2020-02-18 15:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Army_bloodcore 2019-11-08 16:00:50 UTC
Description:
When I am typing formula and exporting it in MS office 2007~2019 format, it becomes a wrong font.

Steps to Reproduce:
1. Create document in LibreOffice
2. Type any formula
3. Save document in MS office 2007~2019 format (*.docx)
4. The result font in MS office will be cambria math

Actual Results:
Formula font must be that I've been setted up.

Expected Results:
Formula font is cambria math.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: ru
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 V Stuart Foote 2019-11-08 19:13:28 UTC
Any better for you if you force LibreOffice to substitute Cambria Math for OpenSymbol.

Tools -> Options -> Fonts  and 'Apply replacement table' checkbox

enter OpenSymbol in the 'Font' droplist, and Cambria Math in the 'Replace with' droplist. Then use the green check mark button to create the replacement entry.

Check 'always' checkbox, and OK to complete the dialog.

Substitution should apply to the GUI, and to any output/printout.

Until bug 101174 is implemented, this should work.
Comment 2 Army_bloodcore 2020-02-18 12:22:31 UTC
I tried that way, and this problem has no solved. With export in *.doc (MS Office 1997~2003) format, there is all right, font saves, but when I am trying to save in *.docx, fonts are ruining. I decided to simplify my documents and make it maximum free from formulas objects to improve compatibility between MS office and LibreOffice. It will take some time.
Comment 3 Timur 2020-02-18 15:01:58 UTC
I confirm the behavior-
But that seems to be a consequence of bug 119170.

*** This bug has been marked as a duplicate of bug 119170 ***