Bug 128691 - EDITING: UI: CALCULATION: LO calc with 'CL' enabled fails simple stresstest, results only shown for top 1.000 cells in a column
Summary: EDITING: UI: CALCULATION: LO calc with 'CL' enabled fails simple stresstest, ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.7.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: QA:needsComment
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-09 22:49 UTC by b.
Modified: 2019-12-28 17:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2019-11-09 22:49:13 UTC
Description:
i wanted to recheck the fix from Dennis Francis for ERR:522, #124270, 

result: 6.4.0.0a1 and 6.2.7.1 can! copy formulas to 'whole columns', but will fail to show the results. results are only shown for the top 1000 cells with the formula in that cloumn, the other cells below show as 'blank', despite they contain the formula (as you can see when clicking into them and checking the formula bar). 

the behaviour had been - much! - better in ver. 4.1.6.2, 

i - assume - it's in since ver. 4.2, 

Eike Rathke once wrote: 'Yes their (shared formulae) dependency handling is broken and was from the beginning it seems.' i - assume - a fault left in from that field or the fixes tried. 

steps to reproduce below, 

reg. 

b. 

Steps to Reproduce:
1. 'simpe LO calc stresstest
2. 'simpler tests may fail too, this script is what i tried ... 
3. type '1' in A1, 
4. type '=A1+1' in A2, 
5. copy down A2 to A3:A1048576, 
6. type '1' in B1048576, 
7. type '=B1048576+1' in B1048575, 
8. copy B1048575 to B1:B1048574, 
9. type '=A1+B1' in C1, 
10. copy C1 to C2:C1048576, 
11. check range C1001:C1048576, 
12. in my test: formula in, display of result omitted, 

Actual Results:
C1001:C1048576 showing no results, 

Expected Results:
normal result '1048577' shown, 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.7.1 (x64)
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: CL, 

6.4.0.0.a1 fails too,
Comment 1 b. 2019-11-10 00:07:34 UTC
simpler tests fail too: 

1. '1' in A1, 
2. '=A1+A1' in B1, 
3. copy A1:B1 to A1:B1048576,
4. check formula and result in B1001, 

works better if you copy to A1:B1048575, 

'edge case'? 

more complicated formulae do work sometimes, when you fill full columns, or full columns without bottom row, and sometimes they won't, 

my feeling: it's more likely to get a fail when the program taks a longer pause with 'Adapt row height' on paste. 

critical! the displayed blank cells are taken as zero values for dependent calculations! 

reg. 

b.
Comment 2 b. 2019-11-10 22:45:17 UTC
looks like this bug only appears with 'CL' enabled, not with 'threaded' or 'unthreaded' ... 

as well in 6.2.7.1 and 6.4.0.0.alpha1+

b.
Comment 3 b. 2019-11-25 23:41:12 UTC
same with: 

Version: 6.2.8.2 (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: CL

'CL' fails while 'threaded' and 'unthreaded' are ok (for this simple test), 

n.b. no correction with 'hard-recalc' (ctrl-shift-F9), range B1001:B1048576 has formula in cell, but shown as blank. 

could someone pls. retest and confirm? 

reg. 



b.
Comment 4 b. 2019-12-21 21:13:17 UTC
Believe me, I'm starting to doubt myself, question myself...

this error was reproducible in my case, and is no longer... 

astonished... 

the only system change in between was the installation of LO-dev 6.5.0.0.a0, version from yesterday ... but as a server image (msiexec -a), so - actually - nothing should be changed on the system? 

all in all the recovery points since the bug report only show effects on Adobe Reader DC, M$ print and desktop services and the newly installed LO versions, 

but the other installed versions (4.1.6.2 regular (did not like msiexec -a?), and 5.0.0.1, 6.2.8.2 and 6.4.0.0b1 all as server image) have 'lost' the bug too!  

someone knows if: 

any system-wide drivers or dll's are replaced during installation? (I have seen something about KBxxxxx flickering across the screen during some runs in the past)

is it conceivable - yes, I know in IT the answer is always 'YES' - that e.g. by installing 4.1.6.2 after! the other versions - after installing 6.2.8.2 4.1.6.2 was installed, OO 4.1.7 was installed and then uninstalled again - the newer versions were somehow affected? 

i'll write this one halfway hungarian and continue testing later ... 

- sorry for deepl-englsh
Comment 5 b. 2019-12-21 23:13:42 UTC
neither original bug nor simpler version from comment #3 reproducible after cleaning all old installations and installing 4.1.6.2, 5.0.0.1, 6.2.8.2, dev6.4.0.0.a0, dev6.5.0.0.a0 as server installs in that order, 

tested with: 

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 209fc9fd7fa433947af0bf86e210d73fa7f5a045
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: CL

assumption: either i'm becoming mad, or the install of e.g. 4.1.6.2 for recheck purposes *after* the actual versions broke something in the system, 

will continue to check also other complaints and set to wfm once i'm sure ...