Download it now!
Bug 128737 - CRASH: Importing a specific file
Summary: CRASH: Importing a specific file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2019-11-12 10:08 UTC by Xisco Faulí
Modified: 2019-11-18 13:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bt Windows (windbg) (72.17 KB, text/plain)
2019-11-12 13:15 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-11-12 10:08:32 UTC
Steps to reproduce:
1. Open attachment 148450 [details] from bug 122829

-> Crash

Reproduced in

Version: 6.4.0.0.alpha1+
Build ID: fea5c10e222b10d83e0081dc1d1b2e678689d250
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by mass-uitesting]
Comment 1 Xisco Faulí 2019-11-12 10:09:31 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a8b1699ca9c7e8c43eff79467451fd1fcb4fde9b

author	Katarina Behrens <Katarina.Behrens@cib.de>	2019-07-01 18:20:02 +0200
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2019-10-25 16:27:04 +0200
commit	a8b1699ca9c7e8c43eff79467451fd1fcb4fde9b (patch)
tree	685f005a1b6c417c3b582d80dce51d0138970cff
parent	edcc3d66f9a107b8d9ffb3c5899e7863cf508484 (diff)
speed-up shape import if shapes need z-order rearranging

Bisected with: bibisect-linux64-6.4

Adding Cc: to Katarina Behrens
Comment 2 Julien Nabet 2019-11-12 13:15:33 UTC
Created attachment 155742 [details]
bt Windows (windbg)

On Win10 with master sources updated today, I could reproduce this.
Comment 3 Commit Notification 2019-11-15 08:56:16 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ce22698c762e25157a643ae099e296da25fa0a59

tdf#128737 svx: fix off-by-one in SdrObjList::sort()

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2019-11-15 09:13:11 UTC
since bubli is on vacation i've taken the liberty to fix it :)
Comment 5 Commit Notification 2019-11-15 11:25:12 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/761672398d44e4d708ddd2d2257026bdb47c4869

tdf#128737 svx: fix off-by-one in SdrObjList::sort()

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-11-18 13:07:07 UTC
Verified in

Version: 6.4.0.0.beta1+
Build ID: c2097477e3a43d75c170a6f7a5daf5dcb2169329
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!