Bug 128761 - The help button opens the HTML document in the text editor
Summary: The help button opens the HTML document in the text editor
Status: RESOLVED DUPLICATE of bug 120248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Help-Viewer
  Show dependency treegraph
 
Reported: 2019-11-13 00:29 UTC by Alberto Salvia Novella
Modified: 2022-05-27 12:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Salvia Novella 2019-11-13 00:29:07 UTC
HOW TO REPRODUCE:
File -> Properties -> Help

RESULT:
The HTML document opens in the text editor.
Comment 1 Xisco Faulí 2019-11-13 14:03:13 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 Xavier Van Wijmeersch 2019-11-13 17:23:49 UTC
I cannot reproduce

warning message: The LibreOffice build-in help is not installed on your computer
then there is a button with "read help online"
pressing the button goes to the website off LibreOffice Help
so for me its not a bug, its working
can be closed as WFM

Version: 6.3.2.2
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Alberto Salvia Novella 2019-11-14 15:38:06 UTC
That's because in your system HTML files are set to open with the web browser, but if you set it the default program as something different you will be able to reproduce it.

LibreOffice shall open the web-page no matter what application is set to open HTML files.
Comment 4 Xisco Faulí 2020-01-23 12:40:31 UTC
(In reply to Alberto Salvia Novella from comment #3)
> That's because in your system HTML files are set to open with the web
> browser, but if you set it the default program as something different you
> will be able to reproduce it.
> 
> LibreOffice shall open the web-page no matter what application is set to
> open HTML files.

LibreOffice will open what is set in your environment. if by default you open html files in a text editor, LibreOffice will open the text editor.
Closing as RESOLVED NOTABUG
Comment 5 Regina Henschel 2020-01-23 13:28:33 UTC
There exists bug 120248 for the request to provide an option to choose the application for to open the help files.
Comment 6 Alberto Salvia Novella 2020-01-23 17:53:04 UTC
What the user is intending is to open the document in the default web browser, not the default file handler.

These are two different use scenarios. One would want to open HTML files on a text editor, but they will ALWAYS want to launch the LibreOffice documentation in a web browser (no option to choose needed).

So this is definitely a bug, and I'm sure you are aware of that. Closing bugs is not fixing them boyo. Don't make me report all these errors just to receive half asses replies, or I will stop reporting. You choose.
Comment 7 Timur 2022-05-27 12:07:51 UTC
Alberto, you set this to New which is contrary to LO policy that bug must be independently confirmed. 
What you say is reasonable, but it's covered by bug 120248 that browser for help files is configurable. 
So I close as a duplicate.

*** This bug has been marked as a duplicate of bug 120248 ***