Bug 128785 - UI: Wrong message text when deleting used style
Summary: UI: Wrong message text when deleting used style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords:
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2019-11-13 18:01 UTC by Gerhard Weydt
Modified: 2019-12-11 08:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test doc with instructions and hardcopy of message (20.75 KB, application/vnd.oasis.opendocument.text)
2019-12-02 12:25 UTC, Gerhard Weydt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Weydt 2019-11-13 18:01:10 UTC
When you try to delete a style that is linked to an object, you get the message:
One or more of the selected styles is in use in this document.
If you delete these styles, text will revert to the parent style.
Do you still wish to delete these styles?

The use of the word "text" is wrong here (is the message copied from Writer?).
I propose "formatting" instead.
Comment 1 Heiko Tietze 2019-12-02 08:12:20 UTC
STR_DELETE_STYLE_USED is used across all modules. We could a) parametrize the call (haven't seen this in the sources yet) or b) rephrase like "If you delete these styles, text/formatting will revert to the parent style...". And c) just accept the minor awkwardness.
Comment 2 Timur 2019-12-02 11:11:17 UTC
This is already confirmed, but for future (and backwards up to OO 3.3) testing, Gerhard please attach minimal sample with steps to test.
Comment 3 Gerhard Weydt 2019-12-02 11:18:26 UTC
@ Heiko: if, as you say, it's one string used all over LibO, then I would vote for simply changing the text.
@ Timur: in most cases I provide an example, here I thought the case very simple. But yes, you are right, testing in many versions is certainly easier having a test case ready to be run.
Comment 4 Gerhard Weydt 2019-12-02 12:25:28 UTC
Created attachment 156248 [details]
test doc with instructions and hardcopy of message
Comment 5 Roman Kuznetsov 2019-12-03 16:55:45 UTC
(In reply to Heiko Tietze from comment #1)
> STR_DELETE_STYLE_USED is used across all modules. We could a) parametrize
> the call (haven't seen this in the sources yet) or b) rephrase like "If you
> delete these styles, text/formatting will revert to the parent style...".
> And c) just accept the minor awkwardness.

Suggest: 

... If you delete these styles, text or objects will revert to the parent style...
Comment 6 Heiko Tietze 2019-12-05 08:03:42 UTC
(In reply to Roman Kuznetsov from comment #5)
> If you delete these styles, text or objects will revert to the parent style.

Sounds like the best solution. Go for it.
Comment 7 Commit Notification 2019-12-06 18:58:44 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fce747852adcc2c20a48e525da872fd3cad3ef04

tdf#128785 Make an attention message more general

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2019-12-08 11:34:20 UTC
(In reply to Commit Notification from comment #7)
> Roman Kuznetsov committed a patch related to this issue.

Is it fixed? Should we backport to 6.4 (one week left until UI freeze)?
Comment 9 Roman Kuznetsov 2019-12-08 13:19:41 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Commit Notification from comment #7)
> > Roman Kuznetsov committed a patch related to this issue.
> 
> Is it fixed? Should we backport to 6.4 (one week left until UI freeze)?

Adolfo against. Because I used "you'll" insted "you will" in that message. You can see his comment in the patch. Is it matter realy?
Comment 10 Heiko Tietze 2019-12-08 18:48:33 UTC
(In reply to Roman Kuznetsov from comment #9)
> Adolfo against. Because I used "you'll" insted "you will" in that message.
> You can see his comment in the patch. Is it matter realy?

Yes, please fix it. Guideline is here https://wiki.documentfoundation.org/Design/Guidelines/UIWriting
Comment 11 Commit Notification 2019-12-08 22:03:28 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7515df5ab28f749168257f82e3bb50cb9187008d

tdf#128785 Make an attention message more general v.2

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-12-11 08:59:48 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c5ba4b47726e2436ab29b7d0039bd75a29b3f532

tdf#128785 Make an attention message more general

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.