Bug 128836 - Cannot toggle edit mode on New (unsaved) Documents.
Summary: Cannot toggle edit mode on New (unsaved) Documents.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2019-11-16 14:00 UTC by sdc.blanco
Modified: 2020-01-13 17:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2019-11-16 14:00:13 UTC
1. Open New Document
2  Add 'Edit Mode' and 'Read Only Mode' to Toolbar
3. Edit menu

Result:  'Edit mode' and 'Read Only Mode" are grayed out in Toolbar.
         'Edit mode' is grayed out in Edit menu

Expect:  Possible to toggle edit mode.

Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: da-DK (en_DK); UI-Language: en-US
Calc: threaded

and 

Version: 6.4.0.0.alpha1 (x64)
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_DK); UI-Language: en-US
Calc: CL

(also tried in safe mode, reset to factory setting, same result)
Comment 1 sdc.blanco 2019-11-16 14:18:02 UTC Comment hidden (obsolete)
Comment 2 sdc.blanco 2019-11-16 16:38:28 UTC
I believe I understand now that only new, unsaved documents cannot toggle Edit Mode. Was confused by it not appearing.  So let this report be understood as query about whether it should appear that way.
Comment 3 Dieter 2019-11-26 09:48:06 UTC
I couldn't find any informations about "Edit Mode" in LO Help. So perhaps there's the need to add some informations to documentation.

cc: Olivier Hallot
Comment 4 Timur 2020-01-13 17:28:18 UTC
I'd say this is NotABug.
But needs to be explained, so I change to Documentation and set New.
There's https://help.libreoffice.org/6.5/en-US/text/shared/02/07070000.html but it's not really well.