Download it now!
Bug 128878 - FILEOPEN DOC: Connectors lost on Import
Summary: FILEOPEN DOC: Connectors lost on Import
Status: RESOLVED DUPLICATE of bug 121649
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: Regressions-AW080
  Show dependency treegraph
 
Reported: 2019-11-18 16:13 UTC by Luke
Modified: 2019-11-18 22:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple diagram with connectors (23.00 KB, application/msword)
2019-11-18 16:14 UTC, Luke
Details
Screenshot 6.1 vs 6.5 (237.86 KB, image/png)
2019-11-18 16:16 UTC, Luke
Details
comparison MSO 2010 and LibreOffice 6.4 (20.05 KB, image/png)
2019-11-18 22:08 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2019-11-18 16:13:44 UTC
In multiple .doc files, I've noticed that LO 6.2+ is not correctly importing connectors. 

Steps to reproduce:
1. Open a .doc with a connector in LO 6.1
1. Open a .doc with a connector in LO 6.2
3. Compare

Expected Results:
1. Connector is imported


Actual  Results:
1. No connector

Version: 6.2.8.2 (x64) Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
bad

Version: 6.1.0.1 (x64) Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
good
Comment 1 Luke 2019-11-18 16:14:18 UTC
Created attachment 155920 [details]
Simple diagram with connectors
Comment 2 Luke 2019-11-18 16:16:37 UTC
Created attachment 155921 [details]
Screenshot 6.1 vs 6.5
Comment 3 raal 2019-11-18 19:17:27 UTC
This seems to have begun at the below commit.
Adding Cc: to Armin Le Grand ; Could you possibly take a look at this one?
Thanks

e703a2bd76b9111224c3191e4603e2452d6a470d is the first bad commit
commit e703a2bd76b9111224c3191e4603e2452d6a470d
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Nov 1 19:43:27 2018 +0100

    source sha:f05a551a6b49916241696481567e32b320c6749b

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-10-31 20:47:49 +0100
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-11-01 19:35:10 +0100
commit	f05a551a6b49916241696481567e32b320c6749b (patch)
tree	30eb942368b05f139d04f9a8b2242af10208b978
parent	8f648a4efad512627a3113dff4fb08111bd369b1 (diff)
tdf#120728 support SvxShape for SdrShape if not inserted
Comment 5 Xisco Faulí 2019-11-18 22:08:56 UTC
Created attachment 155932 [details]
comparison MSO 2010 and LibreOffice 6.4
Comment 6 Xisco Faulí 2019-11-18 22:23:22 UTC
I believe this is a duplicate of bug 121649.
My fix in gerrit < https://gerrit.libreoffice.org/#/c/80375/ > fixes it but for some reason it fails on windows.

*** This bug has been marked as a duplicate of bug 121649 ***