Bug 128896 - LibreOffice 6.4.0.0.beta1 open file not showing anything
Summary: LibreOffice 6.4.0.0.beta1 open file not showing anything
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: x86-64 (AMD64) Mac OS X (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-19 14:01 UTC by Imanuel Ronaldo
Modified: 2020-03-09 16:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Its the picture that only showing the loading cursor and then after that nothing happen when the cursor is become normal (2.65 MB, image/png)
2019-11-19 14:02 UTC, Imanuel Ronaldo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Imanuel Ronaldo 2019-11-19 14:01:10 UTC
Description:
Im using MacOs catalina and LibreOffice 6.4.0.0.beta1. 
i tried to open existing file but only show me the loading cursor.
Its normal to open a new document 

Steps to Reproduce:
1.Install the LibreOffice 6.4.0.0.beta1
2.Copy and paste LibreOffice-dev to applications
3.open the application and click open file

Actual Results:
Only show loading cursor but the browse file window is not open

Expected Results:
It must be open a browse file window but nothing happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Imanuel Ronaldo 2019-11-19 14:02:18 UTC
Created attachment 155941 [details]
Its the picture that only showing the loading cursor and then after that nothing happen when the cursor is become normal
Comment 2 Alex Thurgood 2019-11-20 12:51:10 UTC
I would speculate that this is linked to, or a DUP of, bug 128882.

I can reproduce this in my alpha master build.

Clicking on Finder, for example, sends the beachball spinning.
It seems that Apple's security check calls a dialog requesting the user to authorise access to a folder (Documents, Downloads, or whatever) and perhaps because the app isn't notarized, this fails to happen (or is too slow to display to be of any use).
Comment 3 Alex Thurgood 2019-11-21 09:40:25 UTC
Also reproduced with

Version: 6.5.0.0.alpha0+
Build ID: 19116d1061b287eef600ec6b3f46c362a4abd405
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

1) Open new Draw document
2) Cmd-S ==>> beachball appears, then after a while disappears and nothing else happens.  No file saved.


3) Open new Calc sheet
4) Cmd-S ==>> beachball appears, then after a while disappears and nothing else happens.  No file saved.

5) Open new Writer document
6) Cmd-S ==>> beachball appears, then after a while disappears and nothing else happens.  No file saved.

7) Open new Impress document, choose template
8) Cmd-S ==>> beachball appears, then after a while disappears and nothing else happens. No file saved.

9) Open new Database - db creation wizard starts, accept defaults.
10) Click on Finish, authorisation message request by OS to allow access to Documents folder ==>> beachball, then after a while disappers and nothing else happens, dialog is stuck, only Cancel will allow an escape from dialog, no database saved.
  

etc, etc.
Comment 4 Alex Thurgood 2019-11-21 09:49:50 UTC
WORKAROND:
Go to System > Prefences > Security > Confidentiality

Select "Complete Disk Access"
Add the LibreOfficeDev.app (or whichever version you have that is causing the issue) to the list of applications allowed full disk access.

Validate and restart LO.
Problem solved.

Clearly not in line with Apple's security practice though.
Comment 5 Xisco Faulí 2019-11-21 14:41:37 UTC
Hi Imanuel,
The mac builds for LibreOffice 6.4 beta1 has been reuploaded do to a previous problem.
Could you please download it again from https://downloadarchive.documentfoundation.org/libreoffice/old/6.4.0.0.beta1/mac/x86_64/LibreOfficeDev_6.4.0.0.beta1_MacOS_x86-64.dmg and recheck ?
Comment 6 Xisco Faulí 2019-11-21 14:43:10 UTC
Putting it back to NEW. it doesn't seems like a LibreOffice 6.4 beta1 problem only, Alex confirmed it in master...
Comment 7 Xisco Faulí 2019-11-21 15:00:59 UTC
So, just to clarify:

@Imanuel, could you please try again with https://downloadarchive.documentfoundation.org/libreoffice/old/6.4.0.0.beta1/mac/x86_64/LibreOfficeDev_6.4.0.0.beta1_MacOS_x86-64.dmg ?

@Alex, Do you use a local build or is it a daily build ? if you're using a local build, did you build it on Catalina ?
Comment 8 Timur 2020-03-09 16:35:48 UTC
No response, so let's choose. 
Please do tast current master and be free to set again new if reproducible.