Bug 128898 - import text from file with text-decode failed
Summary: import text from file with text-decode failed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.3.5 target:6.4....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-19 14:10 UTC by mhonline
Modified: 2019-11-29 11:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of failure import text (76.95 KB, image/jpeg)
2019-11-19 14:12 UTC, mhonline
Details
sample-text in ASCII-8bit (DOS) (305 bytes, text/plain)
2019-11-20 12:40 UTC, mhonline
Details
result after import (86.52 KB, image/png)
2019-11-20 18:57 UTC, Oliver Brinzing
Details
select filetype (174.26 KB, image/png)
2019-11-21 18:46 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mhonline 2019-11-19 14:10:14 UTC
Description:
intended to import ascii(8-bit)-text-file to writer

Steps to Reproduce:
1.Open new writer-file
2.use menu-item import text from file
3.choose text-decode

Actual Results:
failed to import - even the window for to dechoose import-method does not come up

Expected Results:
should import


Reproducible: Always


User Profile Reset: No



Additional Info:

since this is essential to my needs I treat it as a regression
Comment 1 mhonline 2019-11-19 14:12:03 UTC
Created attachment 155944 [details]
screenshot of failure import text
Comment 2 mhonline 2019-11-19 14:14:44 UTC
additional info:
workaround: open-ascii-file with external editor/lister - select all and copy - insert to writer 
it works but this is no sultion

m.
Comment 3 Oliver Brinzing 2019-11-19 18:50:47 UTC
Thank you for reporting the bug. 

Please attach a sample document, as this makes it easier for us to verify the bug. 

(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 4 mhonline 2019-11-20 12:40:59 UTC
Created attachment 155972 [details]
sample-text in ASCII-8bit (DOS)
Comment 5 Oliver Brinzing 2019-11-20 18:56:32 UTC
please try:

- Menu File/Open...
- Select from Listbox "FileTypes": [Text - Choose Encoding *.txt]
- Select your *.txt file
- [Open]
- Select from Listbox "Character set": [Western Europe(DOS/OS2-437/US]
Comment 6 Oliver Brinzing 2019-11-20 18:57:13 UTC
Created attachment 155983 [details]
result after import
Comment 7 mhonline 2019-11-21 10:46:26 UTC
come on 
as said before and shown by screenshot, the window past selection "FileTypes": [Text - Choose Encoding *.txt]" does not come up and LO failed.
I case it works for you, you might want to state infos on your OS+LO-Version, to find out, whether issue is caused by different system.


reopend

m.
Comment 8 Oliver Brinzing 2019-11-21 18:46:02 UTC
Created attachment 156008 [details]
select filetype

you need to scroll down with arrow key to select the filtype
[Text - Choose Encoding *.txt]
Comment 9 mhonline 2019-11-21 22:11:28 UTC
oops - sorry - seems not to be related to "text/encoded" only
I can reproduce this issue for import-text-from-file 
with "Text(normal)" and ".doc" with same error-message
while import from .odt does not import anything - without error-message.
So the problems seems to be somewhere else in LO.

m.
Comment 10 Sean Carlos 2019-11-22 07:02:52 UTC
"Insert Text from file" also fails inserting a plain text or a html file.  Inserting a plain text file I get a "Read Error. Error reading file." popup.  Importing an html file I don't even see an error popup.  This is a regression, it worked on Fedora Linux 30; upgrading to 31 (which included Libreoffice upgrade), it broke.

Version: 6.3.3.2.0+
Build ID: 6.3.3.2-3.fc31
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: it-IT (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Oliver Brinzing 2019-11-22 17:23:17 UTC
steps to reproduce:

- open new writer document
- Menu Insert/Text from File...
- select attached "ASCII8BI.TXT"
- choose filetype "[Text - Choose Encoding *.txt]"
- [Open]
-> Read Error. Error reading file

reproducible with:

Version: 6.3.3.2 (x64)
Build-ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

Version: 6.5.0.0.alpha0+ (x64)
Build ID: d04eef858250f97690f32dba17f42d157a8767fc
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

but *not* reproducible with:

Version: 6.2.8.2 (x64)
Build-ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 13 Oliver Brinzing 2019-11-23 10:29:39 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/8f6f9e4217d03d874fb1ce391730a1c893ab6844

tdf#127958 crash adding 2 or more files into writer master document

clean up the memory management here, the SfxMedium wants to own the
passed-in SfxItemSet
Change-Id: I1bafa520ca7b833c4d2df7593649c3720c46e2ce
Reviewed-on: https://gerrit.libreoffice.org/80332
Tested-by: Jenkins
Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
    include/sfx2/docinsert.hxx[diff]
    sfx2/source/doc/docinsert.cxx[diff]


/cygdrive/d/sources/bibisect/bibisect-win64-6.4
$ git bisect good
34c7257b4438143859f534b81c9d3996e8062ac6 is the first bad commit
commit 34c7257b4438143859f534b81c9d3996e8062ac6
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon Oct 7 02:40:14 2019 -0700
    source sha:8f6f9e4217d03d874fb1ce391730a1c893ab6844
    source sha:8f6f9e4217d03d874fb1ce391730a1c893ab6844
:040000 040000 b25ff61f5b2e8334df48372201edf7857a64a722 46990a1a9e68f9bd26bbc9a4b1ba4d5bbbf0efb9 M      instdir

/cygdrive/d/sources/bibisect/bibisect-win64-6.4
$ git bisect log
# bad: [34e6eed6c0c9644b7f6d5b4bad2c0745c2f17b53] source sha:1aa0e52f70e62022cffb499a609ac2def6245166
# good: [8d1eaf05d47fd1c56ddecbe57a9a7c8289ede7f4] source sha:c98b1f1cd43b3e109bcaf6324ef2d1f449b34099
git bisect start 'master' 'oldest'
# good: [2405dfd60d037510a4e8d518c17af3d1d400e345] source sha:2bed8af91fc2654b9ed2432f969d32d5741a529b
git bisect good 2405dfd60d037510a4e8d518c17af3d1d400e345
# bad: [c4cf335626577c71e374bde6ea221a72069260fd] source sha:c8bf651fb9b97eca6af7d1d26c62681cc5c7ec0f
git bisect bad c4cf335626577c71e374bde6ea221a72069260fd
# good: [ac7ceb600fb1a2915cfcdaebe5704f3383a5fdd4] source sha:11feca7a98e21062a2284e7d4dbb21030598cb65
git bisect good ac7ceb600fb1a2915cfcdaebe5704f3383a5fdd4
# good: [1ada86c811c1cb08617638a79151b6e0bd362bd9] source sha:ef98596d62304d64d89b04de04c2bebff76286a0
git bisect good 1ada86c811c1cb08617638a79151b6e0bd362bd9
# good: [19ca804bd6e6cd2845d9930963181f121bc2a713] source sha:f779609a9be63d70b895ba6f0d769e91b5321a2e
git bisect good 19ca804bd6e6cd2845d9930963181f121bc2a713
# good: [ef27cee6b304488eae439c7e4d35f64162e6ffc9] source sha:82297a1e71cd5266b0f0bf0a2ee0c7a3fedce544
git bisect good ef27cee6b304488eae439c7e4d35f64162e6ffc9
# good: [43a104823e9dfa8e437de01b7fa5de11f0160e65] source sha:f9877e1e9abd10bb5bfcae00269c743ca6e62c60
git bisect good 43a104823e9dfa8e437de01b7fa5de11f0160e65
# bad: [78237870b539ac5911e8557c3ebee85cfffdff8b] source sha:ebcaefe7d7e7a0aa3b0c20c84657635462100d07
git bisect bad 78237870b539ac5911e8557c3ebee85cfffdff8b
# good: [3bd5aa8c60d31bf3bc1aa935e339c1fa7b0cfd1b] source sha:48595c805dd5b917e9bd01ad1c2deb4a047c5f7b
git bisect good 3bd5aa8c60d31bf3bc1aa935e339c1fa7b0cfd1b
# good: [d179b791d90a2c334da341bb357ab39395690cec] source sha:439004122498b34433e2394d1d9c55c7d3666ab5
git bisect good d179b791d90a2c334da341bb357ab39395690cec
# bad: [34c7257b4438143859f534b81c9d3996e8062ac6] source sha:8f6f9e4217d03d874fb1ce391730a1c893ab6844
git bisect bad 34c7257b4438143859f534b81c9d3996e8062ac6
# good: [e20338f5f08cdacaf9697e0daf9ddc3ba9ff5209] source sha:46c90ca5f92bfa517b8b89a2d42d60ec3f9f3adc
git bisect good e20338f5f08cdacaf9697e0daf9ddc3ba9ff5209
# first bad commit: [34c7257b4438143859f534b81c9d3996e8062ac6] source sha:8f6f9e4217d03d874fb1ce391730a1c893ab6844
Comment 14 Commit Notification 2019-11-28 07:31:28 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cc4dbe473b0b68dbe120065c1d6a64a087f41ba2

tdf#128898 import text from file with text-decode failed

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2019-11-28 17:05:12 UTC
Hi Noel,
the problem is still reproducible in

Version: 6.5.0.0.alpha0+
Build ID: 4e7e0a29836f0c28471a2f5c605976453f6d29ae
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Steps:
1. Open Writer
2. Go to Insert - Text from File
3. Select ASCII8BI.TXT

-> Read Error
Comment 16 Xisco Faulí 2019-11-28 17:20:44 UTC
Just for the record: In 6.3.3 there is a new crash report < http://crashreport.libreoffice.org/stats/crash_details/104e9f70-d8d7-4d03-9d4f-83ea9c6ce6f0 > that seems related to https://gerrit.libreoffice.org/plugins/gitiles/core/+/8f6f9e4217d03d874fb1ce391730a1c893ab6844 but I don't know how to reproduce
Comment 17 Caolán McNamara 2019-11-28 20:00:19 UTC
I think comment #15 will be fixed by https://gerrit.libreoffice.org/#/c/84024/ which is my fix for bug 129802
Comment 18 Commit Notification 2019-11-29 06:58:56 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/5572f20c0f256140aaab38d3d1b3e53f8588112f

tdf#128898 import text from file with text-decode failed

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2019-11-29 06:59:10 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f3d4c125775b00432a2ef8db329c23c793abc40f

tdf#128898 import text from file with text-decode failed

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Xisco Faulí 2019-11-29 10:03:51 UTC
(In reply to Caolán McNamara from comment #17)
> I think comment #15 will be fixed by
> https://gerrit.libreoffice.org/#/c/84024/ which is my fix for bug 129802

You're right.
Fixed in

Version: 6.5.0.0.alpha0+
Build ID: 63acb8cfa4d66baf48a0fe5cdc9ababb6f981666
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, @Caolán, thanks for fixing this issue!
Comment 21 Commit Notification 2019-11-29 11:11:47 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-4":

https://git.libreoffice.org/core/commit/f5e58a4287bc589d9a3349e162473a0603e4a86f

tdf#128898 import text from file with text-decode failed

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.