Download it now!
Bug 128982 - Exclude changed words in track-changes from "replace all" operations.
Summary: Exclude changed words in track-changes from "replace all" operations.
Status: RESOLVED DUPLICATE of bug 36582
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-23 15:59 UTC by Hussam Al-Tayeb
Modified: 2019-11-30 09:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hussam Al-Tayeb 2019-11-23 15:59:16 UTC
Please exclude changed words in track-changes from "replace all" operations.
This is basically broken in LibreOffice.

When I enable track changes in a .doc or .docx file, and I "replace all"
"This is string one" with "This is not string one", it correctly replaces all instances and tracks the changes.
However, if I run the "replace all" operation again, it replaces the old string again. This is incorrect behavior. Replace all should only search the new string.
Comment 1 Ming Hua 2019-11-24 14:41:08 UTC
I can reproduce the reported behavior in 6.2.8, but only if Edit -> Track Changes -> Show (or View -> Track Changes) is turned on.

Version: 6.2.8.2 (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: zh-CN (zh_CN); UI-Language: en-US
Calc: threaded

I'm not sure it's a bug, though.  At least for "Find" to find tracked deletion seems reasonable.
Comment 2 Hussam Al-Tayeb 2019-11-24 15:26:08 UTC
Try a docx file (NOT odt). It happens there even if I do not enable view -> "Track changes".

It is definitely a bug though. Why would anyone want to return deleted words as result?
Comment 3 Hussam Al-Tayeb 2019-11-24 15:27:16 UTC
(In reply to Hussam Al-Tayeb from comment #2)
> Try a docx file (NOT odt). It happens there even if I do not enable view ->
> "Track changes".
> 
> It is definitely a bug though. Why would anyone want to return deleted words
> as result?

And even be able to replace deleted words by more deleted words creating an infinite loop on 'replace all'?
Comment 4 Timur 2019-11-24 17:48:34 UTC
Please search before reporting.
This seems like duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=36582.
If not, please explain.

*** This bug has been marked as a duplicate of bug 36582 ***
Comment 5 Hussam Al-Tayeb 2019-11-30 09:07:11 UTC
(In reply to Timur from comment #4)
> Please search before reporting.
> This seems like duplicate of
> https://bugs.documentfoundation.org/show_bug.cgi?id=36582.
> If not, please explain.
> 
> *** This bug has been marked as a duplicate of bug 36582 ***

Thank you!