Download it now!
Bug 128988 - Form control events triggered twice
Summary: Form control events triggered twice
Status: RESOLVED DUPLICATE of bug 127921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2019-11-23 21:17 UTC by Andreas Säger
Modified: 2019-11-27 07:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Text document with form controls and a bit of macro code (19.29 KB, application/vnd.oasis.opendocument.text)
2019-11-23 21:17 UTC, Andreas Säger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Säger 2019-11-23 21:17:31 UTC
Created attachment 156065 [details]
Text document with form controls and a bit of macro code

I'm unsure if UI is the right component to report form control issues.

I noticed this when one of my database forms became unusable after upgrading from 6.2 to 6.3. My form catches double-clicks by means of the mouse release script event. Under certain conditions the event is triggered twice. This affects table controls, list boxes, combo boxes, text boxes if they are multi-line and some more controls if they have a spin button but not the spin button control.
The attached text includes a simple macro and lots of form controls. 
The macro fires 2 message boxes when double-clicking a yellow control with LO 6.3.
Comment 1 Oliver Brinzing 2019-11-24 08:33:00 UTC
reproducible with:

Version: 6.3.3.2 (x64)
Build-ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

but not reproducible with:

Version: 6.2.8.2 (x64)
Build-ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 2 Oliver Brinzing 2019-11-24 08:35:04 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/f9905401d8cf2d73576231ebd84cfa5f4f73bcac

commit	f9905401d8cf2d73576231ebd84cfa5f4f73bcac	[log]
author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	
Wed May 08 10:24:18 2019 +0200
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
Thu May 16 15:40:11 2019 +0200
tree	c4151d098222cac20c53f6651595e5cb6ca410d0
parent	1489aa7467a2131e48d2995107d1415d9e59ea9e [diff]

tdf#125170 Deliver mouse events also when clicking into document content

Event listeners are added once VCLXWindow::SetWindow is called.
This never happened for the document content window.
So we need to call Window::GetComponentInterface which will create an XWindowPeer
and then call UnoWrapper::SetWindowInterface which calls VCLXWindow::SetWindow.

After that, event listeners are registered so that we can deliver events.

$ git bisect bad
718ecdad0f67202a569f85e57ea3239d3cd517fe is the first bad commit
commit 718ecdad0f67202a569f85e57ea3239d3cd517fe
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu May 16 06:54:21 2019 -0700
    source sha:f9905401d8cf2d73576231ebd84cfa5f4f73bcac
    source sha:f9905401d8cf2d73576231ebd84cfa5f4f73bcac

:040000 040000 ca8d5691e11681cb931a14fab61f7beb096893ef 4900408c11dc059ee25e5a3ccc7aa69cd2a280b4 M      instdir

/cygdrive/d/sources/bibisect/bibisect-win32-6.3
$ git bisect log
# bad: [18f926e8e18b3d855c2f79ef279febbeb846b8cd] source sha:13152ad88b24cadc836a829b4424a72a152ca9b1
# good: [ea94942caaf195b8d8b2d5c2abb523359ab390e7] source sha:a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'master' 'oldest'
# good: [3aea60569b9190400409ebb93f0a5d323b6fc5d4] source sha:47ce4b87d8a13fc340794ffd9a10d5bd6a15e644
git bisect good 3aea60569b9190400409ebb93f0a5d323b6fc5d4
# good: [3b794d71dd796e467baef082c140bdc77c69c979] source sha:47d25dc5abe000ce751cb1e4dbd1f85f7198ca05
git bisect good 3b794d71dd796e467baef082c140bdc77c69c979
# bad: [a42f6c6e5c4ec8fabee76bfa131fd188f758dc93] source sha:e2aa8f8cb3b93ec3cb14c5c9edc3bbce78c1558f
git bisect bad a42f6c6e5c4ec8fabee76bfa131fd188f758dc93
# good: [95f9e136bc046fbc3b6848d30b228dfcc3a823f8] source sha:f0c3fc59e1eefbec202e0a10553dd6581fc2cae5
git bisect good 95f9e136bc046fbc3b6848d30b228dfcc3a823f8
# good: [34ec72d670699ca24928a9a7cdae62f7bcd384f4] source sha:991f7bf545872ead25513cec761c603bb502e587
git bisect good 34ec72d670699ca24928a9a7cdae62f7bcd384f4
# good: [632ac7dac1cddb396bd1b88adc89335e83378bca] source sha:1489aa7467a2131e48d2995107d1415d9e59ea9e
git bisect good 632ac7dac1cddb396bd1b88adc89335e83378bca
# bad: [5e7114817fc756911abf14a9a54faa9052efe30e] source sha:0353d0e5cdfd2847f1d30c629ce19aa202e43c40
git bisect bad 5e7114817fc756911abf14a9a54faa9052efe30e
# bad: [b44ef4a86e2b8988273e68555cddbc89cf5f86a2] source sha:390bd27d92971d9f523b20510554334e30ae9b9d
git bisect bad b44ef4a86e2b8988273e68555cddbc89cf5f86a2
# bad: [6c16e838decf8d32bf47784be5812f9bb2b837c4] source sha:5ccaa8976fc9bffddacfbe804646f4dce099ddb0
git bisect bad 6c16e838decf8d32bf47784be5812f9bb2b837c4
# bad: [fe50e20b1d57f930e4c170720b201a6f94f3e55a] source sha:141c75847a0fc470915a16c83e80f8effb7a22b6
git bisect bad fe50e20b1d57f930e4c170720b201a6f94f3e55a
# bad: [dae4f838c56b30705d2caa76568a981b7c71b069] source sha:8fb0dbd50c32a2ac2b60730daa362a65589e194f
git bisect bad dae4f838c56b30705d2caa76568a981b7c71b069
# bad: [af8d8dc4922c2b04e571911befc23939d99bbf7f] source sha:daacd89b7513e533e1890526eabdf10c01576596
git bisect bad af8d8dc4922c2b04e571911befc23939d99bbf7f
# bad: [718ecdad0f67202a569f85e57ea3239d3cd517fe] source sha:f9905401d8cf2d73576231ebd84cfa5f4f73bcac
git bisect bad 718ecdad0f67202a569f85e57ea3239d3cd517fe
# first bad commit: [718ecdad0f67202a569f85e57ea3239d3cd517fe] source sha:f9905401d8cf2d73576231ebd84cfa5f4f73bcac
Comment 3 Samuel Mehrbrodt (CIB) 2019-11-27 07:12:24 UTC
This is the same problem as bug 127921 - closing as duplicate (fixed in master and 6.3.4).

*** This bug has been marked as a duplicate of bug 127921 ***