Download it now!
Bug 128995 - Chart: Trend Line shows wrong linear Equation
Summary: Chart: Trend Line shows wrong linear Equation
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Deena Francis
URL:
Whiteboard: target:6.5.0 target:6.4.3
Keywords: bibisectRequest, regression
Depends on:
Blocks: Chart-Trendlines
  Show dependency treegraph
 
Reported: 2019-11-24 15:52 UTC by Robert Großkopf
Modified: 2020-03-02 21:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the attached Calc-file and have a look at the equation. (15.70 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-11-24 15:52 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-11-24 15:52:17 UTC
Created attachment 156075 [details]
Open the attached Calc-file and have a look at the equation.

Open the attached Calc-file.
There are values created for a x-y-chart with y=2.8*x
The chart has been created, the trend line also and the equation also.
The equation is wrong, shows f(x)=2.8x - 2.14...E-15.
Change the value in the chart from 2.80 € to 2.60 €.
Equation is right.
You have to switch "Force Intercept" to "0" to get the right equation also with 2.80 €.
Trend line doesn't recognize the right "start values" every time ...
Comment 1 Robert Großkopf 2019-11-24 16:06:26 UTC
Bug appears in LO 4.4.7.2 up to LO 6.3.3.2, doesn't appear in LO 3.6.7.2. So I set the first version to LO 4.4.7.2 and the keyword "regression".
Comment 2 Regina Henschel 2019-11-24 16:48:34 UTC
I think it is something in addition to accuracy problem in converting between decimal and binary, because the function INTERCEPT returns zero, as expected.
Comment 3 Commit Notification 2019-12-18 21:53:13 UTC
Deena Francis committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8df6f6ec12972ce2c14a162e6f4dd2c0d32367ef

tdf#128995: Special case for single variable regression...

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-01-20 14:18:38 UTC
A polite ping to Deena Francis:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks
Comment 5 Robert Großkopf 2020-01-20 15:17:08 UTC
Works now in LO 6.5.0.0 from 2020-01-20. But shouldn't it be backported to LO 6.4 and LO 6.3?
Comment 6 Deena Francis 2020-01-21 05:30:47 UTC
Fixed in master.
Comment 7 Robert Großkopf 2020-01-21 14:45:57 UTC
(In reply to Deena Francis from comment #6)
> Fixed in master.

Could this be backported to 6.4?
Comment 8 Xisco Faulí 2020-01-28 10:05:57 UTC
(In reply to Robert Großkopf from comment #7)
> (In reply to Deena Francis from comment #6)
> > Fixed in master.
> 
> Could this be backported to 6.4?

https://gerrit.libreoffice.org/#/c/core/+/85504/

Hi Robert,
Could you please verify the issue is fixed in master ?
Comment 9 Robert Großkopf 2020-01-28 16:33:33 UTC
See comment5
Comment 10 Commit Notification 2020-03-02 21:14:05 UTC
Deena Francis committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/71f0e475017e4a979b071e6808361eba187bc00f

tdf#128995: Special case for single variable regression...

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.