Bug 129010 - LibreOffice Math missing in clipboard RTF
Summary: LibreOffice Math missing in clipboard RTF
Status: RESOLVED DUPLICATE of bug 135068
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF-Paste
  Show dependency treegraph
 
Reported: 2019-11-25 11:51 UTC by TomasW
Modified: 2020-07-24 16:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TomasW 2019-11-25 11:51:58 UTC
Description:
In LibreOffice Writer:
Action: Create a text with embedded LibreOffice Math and copy the text.
Result: The Clipboard RTF (Rich Text Format) does not contain any Math (\moMath and related keywords), for consumption in other apps. All formulas are lost.

Noticeable: The RTF File export (of whole document) includes the Math, 
but not Copy selections to clipboard.

Steps to Reproduce:
1.Create any text with embedded LibreOffice Math
2.Select the text.
3.Copy (to clipboard)
4.In clipboard viewers, paste RTF and examine the clipboard RTF data 

Actual Results:
All formulas are missing in Clipboard RTF.

Expected Results:
Clipboard RTF should contain formulas.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-11-26 11:17:06 UTC
I can confirm it in

Версия: 6.4.0.0.alpha1+ (x64)
ID сборки: 25506d15222e583ce5d62b016cf598a9aef65d09
Потоков ЦП: 4; ОС:Windows 10.0 Build 18362; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 2 Michael Warner 2020-06-01 01:54:50 UTC
I was able to reproduce this in:
7.1.0.0.alpha0+
7db6b280e9703ad8786b6019ec6ac9fd31d146e7
on Linux

Using these steps:
1. Create some text with an embedded Math formula
2. Select the text
3. Copy
4. Paste back into LibreOffice Writer
5. Observe the formula is present
6. Paste Special, Rich Text Formatting
7. Observe the formula is not present
Comment 3 Xisco Faulí 2020-07-24 13:46:27 UTC
I guess we can close this issue as a dupe of bug 135068

*** This bug has been marked as a duplicate of bug 135068 ***
Comment 4 TomasW 2020-07-24 15:08:19 UTC
Reopened this report, because the issue is not paste (side effect), 
but the primary bug is the omission of putting RTF math onto Clipboard,
and this bug is regardless of how much (part or whole) of the document is selected and copied.
Comment 5 V Stuart Foote 2020-07-24 16:00:48 UTC
(In reply to TomasW from comment #4)
> Reopened this report, because the issue is not paste (side effect), 
> but the primary bug is the omission of putting RTF math onto Clipboard,
> and this bug is regardless of how much (part or whole) of the document is
> selected and copied.

For text or formula there is no RTF to be found on a document canvas. That is all generated in an clipboard filter/export filter plain and simple. 

Work to provide RTF math in the filter would be no different than filter parsing out to MathML, or even LaTex if we wanted to play nice.

IIUC the Writer RTF filter services both clipboard and file export stream use--not parsing the OLE math objects for inclusion in the clipboard formats is exactly issue of bug 135068.

*** This bug has been marked as a duplicate of bug 135068 ***