Download it now!
Bug 129083 - EDITING Rich text/HTML paste from Calc into Writer table doesn't spread content into the existing cells
Summary: EDITING Rich text/HTML paste from Calc into Writer table doesn't spread conte...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords: needUITest
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2019-11-28 13:47 UTC by NISZ LibreOffice Team
Modified: 2020-03-25 13:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Calc (10.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-11-28 13:48 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in current Writer (33.09 KB, image/png)
2019-11-28 13:48 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-11-28 13:47:34 UTC
Description:
Copying Calc table contents to Writer table resulted in the Calc cell contents being copied to Writer table cells. In recent 6.4 branch this changed to all copied contents being pasted to a single cell as an RTF table.

Steps to Reproduce:
1.	Open attached fruits.ods file and copy the A1:A4 cells
2.	Open a new Writer table and insert a 1 column 4 rows table
3.	Enter the first cell of the table and paste the clipboards contents


Actual Results:
A small RTF table (same as if Paste Special – Rich Text Formatting were selected) is inserted into the first cell.

Expected Results:
The 4 copied cells contents should be pasted into the 4 Writer table cells.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 7e09d08807b5ba2fd8b9831557752a415bdad562
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-US (hu_HU); UI-Language: en-US
Calc: CL

But not in:
Verzió: 6.3.0.4 (x86)
Build az.: 057fc023c990d676a43019934386b85b21a9ee99
CPU szálak: 4; OS: Windows 6.3; Felületmegjelenítés: GL; VCL: win; 
Területi beállítások: hu-HU (hu_HU); Felület nyelve: hu-HU
Calc: CL
Comment 1 NISZ LibreOffice Team 2019-11-28 13:48:16 UTC
Created attachment 156167 [details]
Example file from Calc
Comment 2 NISZ LibreOffice Team 2019-11-28 13:48:34 UTC
Created attachment 156168 [details]
Screenshot of the problem in current Writer
Comment 3 NISZ LibreOffice Team 2019-11-28 13:48:57 UTC
Bibisected using bibisect-win64-6.4 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=e9e6d4b058e13165f3dde1ca7822eec97dfe8aa7 

author	Jan Holesovsky <kendy@collabora.com>	2019-09-26 13:35:55 +0200
committer	Jan Holesovsky <kendy@collabora.com>	2019-09-27 09:54:06 +0200

tdf#116685: Make the RICHTEXT take precedence over EMBED_SOURCE.

Adding CC to: Jan Holesovsky
Comment 4 Aron Budea 2019-11-28 14:10:14 UTC
Confirmed in LO 6.5.0.0.alpha0+ (08ce9a9293523c2b49e3beda62c0eb0f75be2745) / Ubuntu.

(In reply to NISZ LibreOffice Team from comment #0)
> Actual Results:
> A small RTF table (same as if Paste Special – Rich Text Formatting were
> selected) is inserted into the first cell.
> 
> Expected Results:
> The 4 copied cells contents should be pasted into the 4 Writer table cells.
As I can see bug 37223's fix was only implemented for OLE tables, so this seems more of an incomplete fix there rather than a regression.
Comment 5 Aron Budea 2019-11-29 06:02:34 UTC
(In reply to Aron Budea from comment #4)
> As I can see bug 37223's fix was only implemented for OLE tables, so this
> seems more of an incomplete fix there rather than a regression.
Right, I could reproduce the issue with paste special to rich text and HTML formats even in 6.3.0.4. I'm assuming it's there since the beginnings, and have updated the bug details accordingly. Having a unit/ui test for this functionality in the end would be nice.
Comment 6 Commit Notification 2019-12-04 11:23:54 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/84a6d8b79455291f35211e4bd6aad3c7a0fcc9bc

tdf#129083 Writer: fix native paste from Calc

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-12-05 09:27:27 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/458c8ef1fa78ac57cc5593a61c64d6049307d21e

tdf#129083 Writer: fix native paste from Calc

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.