Download it now!
Bug 129122 - Make all function names distinguishable
Summary: Make all function names distinguishable
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack, needsUXEval, topicUI
Depends on:
Blocks:
 
Reported: 2019-12-01 08:29 UTC by Mike Kaganski
Modified: 2019-12-01 09:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-12-01 08:29:50 UTC
Searching for functions in Customize dialog, many names appearing in the Function box don't tell anything to the user. E.g.: type "inc" in the search box of the Keyboard customization in Calc, and see the three identical "Increase" strings appeared in the Function box. Do you see what each of they actually for? No. Their names are: (1) indistinguishable from each other; and (2) not telling anything about what they do. Increase what? Font? Cell width? Cell height? User confusion?

The function names must be telling, not only in contexts where they appear e.g. in menus - surrounded by other items related to the function and maybe with some grouping/caption, but also when you see them outside of context. Maybe functions could have two names (full/short), but in any case, user needs to be able to see which function does what and how it is different from other functions having similar names.

So the task is: for each function in the list in every component, to type its name in the search box, look at the resulting found list, find out what each of found function is, and improve names of each function, so that user sees understandable and usable results.

The resulting changes must also be checked that they don't make other uses of the names (e.g. in menus / context menus) not worse. But some increase in length of names by itself should not be stopper, if the result is clearer for user.
Comment 1 Mike Kaganski 2019-12-01 09:28:47 UTC

*** This bug has been marked as a duplicate of bug 108458 ***