Bug 129133 - Save As does not work in 6.3.3_MacOS_x86-64
Summary: Save As does not work in 6.3.3_MacOS_x86-64
Status: RESOLVED DUPLICATE of bug 128233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2019-12-01 15:16 UTC by Phil
Modified: 2020-04-10 15:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil 2019-12-01 15:16:23 UTC
Description:
LibreOffice 6.3.3_MacOS_x86-64 hangs when trying to use Save As. There is no problem with 6.2.8_MacOS_x86-64. Tried downloading and installing a fresh version but the problem still exists.

Rebooted computer with no change -- still does not work.

Observed Behavior: Get spinning beach ball for about 15 sec. then the ball disappears and there is no action.

Mac mini (2018), 3.2 GHz i7, 16GB, 1TB SSD, macOS Catalina 10.15.1.

Steps to Reproduce:
1.Created a writer document
2.Attemped to use File > Save As 


Actual Results:
Got spinning beach ball for about 15 sec. but the save as menu doesn't appear. Rebooting does not help.

The previous release (6.2.8) works fine.

Expected Results:
The "Save As menu" opens.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
OpenGL report.

Renderer: Intel(R) UHD Graphics 630
Vendor: Intel Inc.
Version: 4.1 INTEL-14.2.16
Device: Macmini8,1
Shading language version: 4.10


System:
Mac mini (2018), 3.2 GHz i7, 16GB, 1TB SSD, macOS Catalina 10.15.1.
Comment 1 Roman Kuznetsov 2019-12-01 16:28:41 UTC
>The previous release (6.2.8) works fine.

Phil, are you sure that 6.2.8 works fine on Catalina too?

I can confirm problem with "Save as" in

Version: 6.2.7.1
Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

and in

Версия: 6.3.3.2
ID сборки: a64200df03143b798afd1ec74a12ab50359878ed
Потоков ЦП: 4; ОС:Mac OS X 10.15.1; Отрисовка ИП: по умолчанию; VCL: osx; 
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded

I think it's the "New Catalina stupid security policy" problem

Xisco, some opinions?
Comment 2 Roman Kuznetsov 2019-12-01 16:32:56 UTC
hm ... can't repro in

Version: 6.5.0.0.alpha0+
Build ID: 71c5b374deb35993d0af3e953ff0cdfc64d76aab
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: GL; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

but can in

Version: 6.5.0.0.alpha0+
Build ID: 71c5b374deb35993d0af3e953ff0cdfc64d76aab
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded



Phil try enable OpenGL and then retest your problem with "Save as"
Comment 3 Phil 2019-12-01 17:08:00 UTC
(In reply to Roman Kuznetsov from comment #1)
> >The previous release (6.2.8) works fine.
> 
> Phil, are you sure that 6.2.8 works fine on Catalina too?
> 
> I can confirm problem with "Save as" in
> 
> Version: 6.2.7.1
> Build ID: 23edc44b61b830b7d749943e020e96f5a7df63bf
> CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
> Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> and in
> 
> Версия: 6.3.3.2
> ID сборки: a64200df03143b798afd1ec74a12ab50359878ed
> Потоков ЦП: 4; ОС:Mac OS X 10.15.1; Отрисовка ИП: по умолчанию; VCL: osx; 
> Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
> Calc: threaded
> 
> I think it's the "New Catalina stupid security policy" problem
> 
> Xisco, some opinions?

I suspect that this is related to the Catalina gatekeeper change.

OpenGL is enabled.

Save As does not work in:

Version: 6.2.8.2
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 12; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

	This is strange because it worked at first in 6.2.8.2

Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 12; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.beta1
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 12; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Phil 2019-12-01 17:46:22 UTC
The problem that I reported is definitely due to Catalina gatekeeper changes.

Test:

1. Open macOS System Preferences > Security and Privacy
2. Select Privacy tab
3. Select Full Disk Access
4. Add LibreOffice to the "allowed" list (password required)

Load LibreOffice.

I tested with Version: 6.4.0.0.beta1, 
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920

Save As now works. I haven't tested with earlier versions, but I suspect that they will work once Full Disk Access has been granted. It might also work with the Files and Folders option rather than the Full Disk Access option, but I haven't tested this.
Comment 5 Phil 2019-12-01 18:01:23 UTC
Tested the procedure with:

Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed

"Save As" works perfectly after the Catalina gatekeeper modification.
Comment 6 Roman Kuznetsov 2019-12-01 18:29:16 UTC
Ok, let's close it as WFM. Phil, thank you
Comment 7 Alex Thurgood 2019-12-02 08:42:51 UTC
Actually a DUP of bug 128233

The point being that you shouldn't have to separately give LibreOffice full disk access via such trickery.

See comment 6 in bug 128233

*** This bug has been marked as a duplicate of bug 128233 ***