Bug 129191 - FORMATTING: Default font for headers/footers in CSV-like file changed from 6.3.3 and up
Summary: FORMATTING: Default font for headers/footers in CSV-like file changed from 6....
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.3.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0.1 target:6.3.4 target:6....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-12-04 19:48 UTC by Naram Qashat
Modified: 2020-01-28 10:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naram Qashat 2019-12-04 19:48:15 UTC
Description:
I typically open up extensionless files that are in a CSV-like format (specifically tab delimited) in LibreOffice Calc. The fonts for headers/footers in Calc since 6.3.3 (specifically 6.3.3.1) are no longer respecting the Default style font. The default font on the Default style is Liberation Sans, Regular style at 10 pt, as seen when I click on Styles in the Sidebar, right-click on Default, choose Modify, then go to the Font tab.

When I go to Insert > Headers and Footers, the header of the dialog box says "Page Style: Default". I can see what font is being used by clicking on the Text Attributes button next to Custom header. In 6.3.2 (specifically 6.3.2.2), it says Liberation Sans, Regular style, 10 pt. But in 6.3.3, it says Liberation Serif, Regular style, 12pt.

However, in both cases, if I go to Print Preview, it shows the header in Liberation Sans at 10 pt, even in 6.3.3. This holds true for both the pre-existing header that shows the sheet name by default as well as a custom header added to the left area. If I select the custom header added to the left area and click on Text Attributes and only change the style and/or size, it shows the updated style and/or size with the existing font, but still is Liberation Sans in the preview. The only way in 6.3.3 to get Liberation Serif to be the actual header font is to change the font itself to something else then back to Liberation Serif.

I experience this problem with 6.4 Beta1 as well, so it is not a single version issue. It seems to be some sort of regression that happened between 6.3.2.2 and 6.3.3.1.

I have only tested this under Windows 10 64-bit. I am unsure if it happens with other OSes or architectures.

Steps to Reproduce:
1. Open an extensionless tab delimited file in Calc.
2. Go to Insert > Headers and Footers.
3. Click on the Text Attributes button next to Custom header.
4. Look at the font selection.

Actual Results:
Dialog box says Liberation Serif, Regular style at 12pt.

Expected Results:
Dialog box says Liberation Sans, Regular style at 10pt.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 16; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

NOTE: I did not check the box below for OpenGL as it was disabled on one of the computers I was testing this bug on even though it was enabled on the computer I copied the about text above from.
Comment 1 Mike Kaganski 2019-12-04 20:29:42 UTC
Regression after https://git.libreoffice.org/core/+/2cebba0e4042ca2cab37cf38874c2576c2ac6a6f

CC: Caolan: could you please take a look?
Comment 2 Caolán McNamara 2019-12-05 10:17:27 UTC
gah!, EditEngine has a non-virtual void SetText( const EditTextObject& rTextObject ); ScEditEngineDefaulter inherit from EditEngine and does 

using EditEngine::SetText
void            SetText( const EditTextObject& rTextObject );

so has another with the same signature that does something different, to calling via an EditEngine pointer got the base version
Comment 3 Commit Notification 2019-12-05 16:48:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/b00346bcb81535b4a5c79a4ad450bb11bd663182

Resolves: tdf#129191 text properties in header/footer not set

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-12-05 19:39:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-4":

https://git.libreoffice.org/core/commit/54858bbc2ccd93a256d10ad155638da92e4126fd

Resolves: tdf#129191 text properties in header/footer not set

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-12-06 10:29:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1ca9c335a564babbfd19801129c1e010666cdf60

Resolves: tdf#129191 text properties in header/footer not set

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-12-09 12:07:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/7a0d7921dd1151427385e1b07398fffe1550c772

Resolves: tdf#129191 text properties in header/footer not set

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Naram Qashat 2019-12-13 18:39:02 UTC
I just installed 6.3.4.2, and it looks like now it is defaulting to Calibri Regular 12 pt instead of the Default style's Liberation Sans Regular 10 pt.
Comment 8 Naram Qashat 2019-12-13 18:40:32 UTC
Oops, false alarm, it was because I copied and pasted from another document that was using Calibri 12 pt. It is actually using Liberation Sans 10 pt as expected.
Comment 9 Xisco Faulí 2020-01-20 14:25:50 UTC
A polite ping to Caolán McNamara:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks
Comment 10 Xisco Faulí 2020-01-28 10:06:46 UTC
(In reply to Naram Qashat from comment #8)
> Oops, false alarm, it was because I copied and pasted from another document
> that was using Calibri 12 pt. It is actually using Liberation Sans 10 pt as
> expected.

Setting to VERIFIED then.
@Caolán, thanks for fixing it!