Bug 129215 - PDF Hyperlink in writer not resolving.
Summary: PDF Hyperlink in writer not resolving.
Status: RESOLVED DUPLICATE of bug 125607
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-05 21:51 UTC by Steve
Modified: 2019-12-09 17:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2019-12-05 21:51:22 UTC
Inserting a hyperlink to a local PDF file into a Writer doc (odt) will post, but fails to open because of the following error.

"file:///Users/U15b/5_DOCS/t.481%20Passport%20Lorena%20Application.pdf" is not an absolute URL that can be passed to an external application to open it.

* removing spaces in the PDF filename does not help.
* this does work with the PDF link inside a spreadsheet (ods) file.

Version info is as follows.
Version: 6.2.8.2
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 8; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Thank you.

=Steve.
Comment 1 Dieter 2019-12-06 07:24:08 UTC
Steve, thank you for reporting the bug. Could you please

a) try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?

and (if this doesn't solve your problem)

b) provide a clearer set of step-by-step instructions on how to reproduce the problem or add a sample document.

Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Timur 2019-12-09 17:37:10 UTC
There are bugs with simialr error, bug 128522 or bug 128969.
But this one seems like a duplicate of bug 125607.
Please test with master LO or with LO 6.3.4 when it's out.
If you still have a problem, set back Unconfirmed.

*** This bug has been marked as a duplicate of bug 125607 ***