Download it now!
Bug 129218 - VIEWING: Some svg are incorrectly rendered (maybe due to css)
Summary: VIEWING: Some svg are incorrectly rendered (maybe due to css)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-05 23:41 UTC by Do
Modified: 2019-12-11 14:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Mentioned SVG images (4.54 KB, image/svg)
2019-12-05 23:45 UTC, Do
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Do 2019-12-05 23:41:30 UTC
Description:
I modify some svg using css in place xml attribute and I used nested translate.
So, some element are not displyed.

Just on Ubuntu version.

Steps to Reproduce:
1. add GaussianDistribugion_old.svg
2. add GaussianDistribugion.svg
3. add Tao_symbol.svg
4. add Luscher.svg

Actual Results:
1. good
2. miss the curve (path)
3. left line is not displyed
4. image is not centred and text is not displayed

Expected Results:
take a look in a browser or on windows


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RS780 (DRM 2.50.0 / 5.3.0-24-generic, LLVM 9.0.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.2.1
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.2.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.2.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 1 Do 2019-12-05 23:45:02 UTC
Created attachment 156339 [details]
Mentioned SVG images

Images
Comment 2 Xisco Faulí 2019-12-11 14:02:42 UTC
Hi Do,
Thanks for reporting this issue.
A few clarifications:
1. Recently I've fixed some svg issues my self. Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
2. OTOH, could you please report each issue separately? the different issues in each file might have different root causes.
Thanks in advance. Closing as RESOLVED WONTFIX