Download it now!
Bug 129245 - Mailmerge: Dialog size should be remembered and increased dialog should enlarge records area and not space above OK/Cancel buttons
Summary: Mailmerge: Dialog size should be remembered and increased dialog should enlar...
Status: RESOLVED DUPLICATE of bug 47890
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2019-12-06 16:45 UTC by jimmysleep
Modified: 2020-02-08 17:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
serial letter select-data-for-printing dialog (40.17 KB, image/png)
2019-12-06 16:45 UTC, jimmysleep
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jimmysleep 2019-12-06 16:45:00 UTC
Created attachment 156370 [details]
serial letter select-data-for-printing dialog

Hello,

I work a lot with the  serial letter function of the libre office writer. There are two things bothering me and also seem not the proper behavior.

There is this print dialog where I can select the rows of my data table that I want to print as serial letter. I have about 500 rows in my table (growing every day, since it is an adress table for online orderings) and I will always select the new ones on the bottom. So I have to scroll down. Therefor, I resize the dialog to get a better overview. 

And here comes the bothering parts:
1. The distribution of the components through the layout seem unlucky choosen. The table part should take all the unused space in the dialog and grow with it, instead of not use the free space at all. Take a look to the attached picture to get the idea. 
2. The dialog position is saved after closing the dialog, but the dialog size is not. Seems unintentional to me too.

If there are any question, don't hasitate to ask.
Comment 1 Timur 2019-12-09 18:41:39 UTC
First, let me draw your attention to bug 86672 and bug 52586.

As for bug report, I understand from attachment 156370 [details] this and change title:
"Mailmerge: Dialog size should be remembered and increased dialog should enlarge records area and not space above OK/Cancel buttons"

Actually, those may be two issues, but let's have them both so far. If a single one resolved, it's easy to split. I set as New, unless UX changes that.
Comment 2 Heiko Tietze 2019-12-10 08:27:15 UTC
Definitely one of the worst dialogs, almost everything violates usability. Ideally we separate the layout part from the printing so Records and Output is taken subsequently at the print dialog. Alternatively we add a tab to the print dialog. And toolbars have no place in property dialogs, all functions to manipulate the dataset belong to the mm wizard.

At this point, the mm print dialog looks a bit obsolete. What exactly is the use case in this step?
Comment 3 Timur 2020-02-08 17:06:03 UTC
Already reported.

*** This bug has been marked as a duplicate of bug 47890 ***