Bug 129321 - HELP-LINK: Wrong link in page style dialog
Summary: HELP-LINK: Wrong link in page style dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0.1
Keywords: bibisected, bisected
Depends on:
Blocks: Help-Link
  Show dependency treegraph
 
Reported: 2019-12-11 09:13 UTC by Dieter
Modified: 2020-01-12 22:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Xisco Faulí 2019-12-11 09:44:50 UTC
Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: b9d6ea1dd7541c4bd866571f9e3f0aa894687c07
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded


started to happen after https://cgit.freedesktop.org/libreoffice/core/commit/?id=34e83dd95260d534464ff9a61eddefdde136013c, before the main writer page was open
Comment 2 Xisco Faulí 2019-12-11 09:56:48 UTC
Even if this block of code is deleted < https://opengrok.libreoffice.org/xref/core/svx/source/dialog/hdft.cxx?r=981654f6#155 > the footer help page is still displayed.

@Caolán, I thought you might be interested in this issue...
Comment 3 Caolán McNamara 2019-12-11 10:42:41 UTC
if the toplevels had different helpids this wouldn't happen
Comment 4 Commit Notification 2019-12-11 11:49:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/16ac2e562235fb6c908ada4ce1af4cd67c473df3

tdf#129321 add specific ids for header/footer pages
Comment 5 Commit Notification 2019-12-11 12:37:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/help/commit/8030c1946f37e4d1b8e6ceff25bc72ead4a09fbf

tdf#129321 add specific ids for header/footer pages
Comment 6 Commit Notification 2019-12-11 14:09:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/954bb75be3e78290fc944bd49015e047476df2d5

tdf#129321 add specific ids for header/footer pages

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-12-11 14:24:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/0f1c86cb4099e7092804a571502b9e1e8575605b

tdf#129321 add specific ids for header/footer pages

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2019-12-11 14:26:58 UTC
fixed in master and 6-4
Comment 9 Dieter 2019-12-15 12:12:43 UTC
help for header is now correct, but target of help for footer is now wrong:

https://help.libreoffice.org/6.5/en-GB/text/swriter/main0000.html?System=WIN&DbPAR=WRITER

Version: 6.5.0.0.alpha0+ (x64)
Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 10 Caolán McNamara 2019-12-15 19:21:56 UTC
We'll probably have to give it some time because I don't know when or how the online html pages get regenerated from helpcontent2 which had the extra bookmarks added to it
Comment 11 Dieter 2020-01-12 22:06:44 UTC
Verified with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 350d25da375f221edfa37309324ce3c68cf297ef
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Caolán, thanks for fixing it!